summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--configure.in19
-rw-r--r--docs/index.html16
-rw-r--r--etc/modules.ini2
-rw-r--r--ohmd/ohm-plugin.h1
-rw-r--r--plugins/Makefile.am20
-rw-r--r--plugins/backlight/backlight6
-rw-r--r--plugins/glue/Makefile.am14
-rw-r--r--plugins/glue/acadapter/.gitignore (renamed from plugins/acadapter/.gitignore)0
-rw-r--r--plugins/glue/acadapter/Makefile.am (renamed from plugins/acadapter/Makefile.am)0
-rw-r--r--plugins/glue/acadapter/README (renamed from plugins/acadapter/README)0
-rw-r--r--plugins/glue/acadapter/acadapter (renamed from plugins/acadapter/acadapter)0
-rw-r--r--plugins/glue/acadapter/ohm-plugin-acadapter.c (renamed from plugins/acadapter/ohm-plugin-acadapter.c)0
-rw-r--r--plugins/glue/backlight/.gitignore (renamed from plugins/backlight/.gitignore)0
-rw-r--r--plugins/glue/backlight/Makefile.am (renamed from plugins/backlight/Makefile.am)0
-rw-r--r--plugins/glue/backlight/README (renamed from plugins/backlight/README)0
-rw-r--r--plugins/glue/backlight/backlight2
-rw-r--r--plugins/glue/backlight/ohm-plugin-backlight.c (renamed from plugins/backlight/ohm-plugin-backlight.c)130
-rw-r--r--plugins/glue/battery/.gitignore (renamed from plugins/battery/.gitignore)0
-rw-r--r--plugins/glue/battery/Makefile.am (renamed from plugins/battery/Makefile.am)0
-rw-r--r--plugins/glue/battery/README (renamed from plugins/battery/README)0
-rw-r--r--plugins/glue/battery/battery (renamed from plugins/battery/battery)0
-rw-r--r--plugins/glue/battery/ohm-plugin-battery.c (renamed from plugins/battery/ohm-plugin-battery.c)0
-rw-r--r--plugins/glue/dpms/.gitignore (renamed from plugins/dpms/.gitignore)0
-rw-r--r--plugins/glue/dpms/Makefile.am (renamed from plugins/dpms/Makefile.am)0
-rw-r--r--plugins/glue/dpms/README (renamed from plugins/dpms/README)0
-rw-r--r--plugins/glue/dpms/dpms (renamed from plugins/dpms/dpms)0
-rw-r--r--plugins/glue/dpms/ohm-plugin-dpms.c (renamed from plugins/dpms/ohm-plugin-dpms.c)0
-rw-r--r--plugins/glue/idle/.gitignore (renamed from plugins/idle/.gitignore)0
-rw-r--r--plugins/glue/idle/Makefile.am (renamed from plugins/idle/Makefile.am)0
-rw-r--r--plugins/glue/idle/README (renamed from plugins/idle/README)0
-rw-r--r--plugins/glue/idle/idle (renamed from plugins/idle/idle)0
-rw-r--r--plugins/glue/idle/ohm-plugin-idle.c (renamed from plugins/idle/ohm-plugin-idle.c)0
-rw-r--r--plugins/glue/powerstatus/.gitignore (renamed from plugins/powerstatus/.gitignore)0
-rw-r--r--plugins/glue/powerstatus/Makefile.am (renamed from plugins/powerstatus/Makefile.am)0
-rw-r--r--plugins/glue/powerstatus/README (renamed from plugins/powerstatus/README)0
-rw-r--r--plugins/glue/powerstatus/ohm-plugin-powerstatus.c (renamed from plugins/powerstatus/ohm-plugin-powerstatus.c)0
-rw-r--r--plugins/glue/powerstatus/powerstatus (renamed from plugins/powerstatus/powerstatus)0
-rw-r--r--plugins/glue/timeremaining/.gitignore (renamed from plugins/timeremaining/.gitignore)0
-rw-r--r--plugins/glue/timeremaining/Makefile.am (renamed from plugins/timeremaining/Makefile.am)0
-rw-r--r--plugins/glue/timeremaining/README (renamed from plugins/timeremaining/README)0
-rw-r--r--plugins/glue/timeremaining/ohm-plugin-timeremaining.c (renamed from plugins/timeremaining/ohm-plugin-timeremaining.c)0
-rw-r--r--plugins/glue/timeremaining/timeremaining (renamed from plugins/timeremaining/timeremaining)0
42 files changed, 54 insertions, 156 deletions
diff --git a/configure.in b/configure.in
index 5fc045e..b3d62c5 100644
--- a/configure.in
+++ b/configure.in
@@ -1,6 +1,6 @@
AC_PREREQ(2.52)
-AC_INIT(ohm, 0.0.2)
+AC_INIT(ohm, 0.0.3)
AC_CONFIG_SRCDIR(ohmd)
AM_INIT_AUTOMAKE(AC_PACKAGE_NAME, AC_PACKAGE_VERSION)
AM_CONFIG_HEADER(config.h)
@@ -299,13 +299,16 @@ ohm.conf
Makefile
etc/Makefile
plugins/Makefile
-plugins/acadapter/Makefile
-plugins/dpms/Makefile
-plugins/idle/Makefile
-plugins/powerstatus/Makefile
-plugins/timeremaining/Makefile
-plugins/backlight/Makefile
-plugins/battery/Makefile
+plugins/glue/Makefile
+plugins/glue/acadapter/Makefile
+plugins/glue/dpms/Makefile
+plugins/glue/idle/Makefile
+plugins/glue/powerstatus/Makefile
+plugins/glue/timeremaining/Makefile
+plugins/glue/backlight/Makefile
+plugins/glue/battery/Makefile
+plugins/policy/Makefile
+plugins/policy/display/Makefile
ohmd/Makefile
po/Makefile.in
docs/Makefile
diff --git a/docs/index.html b/docs/index.html
index 2dab382..131b3f8 100644
--- a/docs/index.html
+++ b/docs/index.html
@@ -1,18 +1,6 @@
-<html><head><meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1"><title>Open Hardware Manager 0.0.1 Documentation</title><link rel="stylesheet" href="docbook.css" type="text/css"><meta name="generator" content="DocBook XSL Stylesheets V1.69.1"><meta name="description" content='Executive Summary
- OHM is a small open source systems daemon which sits above HAL and
- abstracts out common hardware management tasks such as system wide
- inhibit action control and controlling heat dissipation on embedded
- devices.
- OHM is built using a lightweight plugin architecture.
- Each plugin can query data from HAL or execute methods on HAL devices
- and expose preferences for session programs to modify.
- OHM is product and vendor neutral and is currently being developed by
- a small team of developers.
-
- OHM : "Resistance is futile"
- '></head><body bgcolor="white" text="black" link="#0000FF" vlink="#840084" alink="#0000FF"><div class="book" lang="en"><div class="titlepage"><div><div><h1 class="title"><a name="index"></a>Open Hardware Manager 0.0.1 Documentation</h1></div><div><div class="authorgroup"><div class="author"><h3 class="author"><span class="firstname">Richard</span> <span class="surname">Hughes</span></h3><div class="affiliation"><div class="address"><p><br>
+<html><head><meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1"><title>Open Hardware Manager 0.0.3 Documentation</title><link rel="stylesheet" href="docbook.css" type="text/css"><meta name="generator" content="DocBook XSL Stylesheets V1.72.0"><meta name="description" content='Executive Summary OHM is a small open source systems daemon which sits above HAL and abstracts out common hardware management tasks such as system wide inhibit action control and controlling heat dissipation on embedded devices. OHM is built using a lightweight plugin architecture. Each plugin can query data from HAL or execute methods on HAL devices and expose preferences for session programs to modify. OHM is product and vendor neutral and is currently being developed by a small team of developers. OHM : "Resistance is futile"'></head><body bgcolor="white" text="black" link="#0000FF" vlink="#840084" alink="#0000FF"><div class="book" lang="en"><div class="titlepage"><div><div><h1 class="title"><a name="index"></a>Open Hardware Manager 0.0.3 Documentation</h1></div><div><div class="authorgroup"><div class="author"><h3 class="author"><span class="firstname">Richard</span> <span class="surname">Hughes</span></h3><div class="affiliation"><div class="address"><p><br>
            <code class="email">&lt;<a href="mailto:richard@hughsie.com">richard@hughsie.com</a>&gt;</code><br>
-          </p></div></div></div></div></div><div><p class="releaseinfo">Version 0.0.1</p></div><div><div class="abstract"><p class="title"><b>Executive Summary</b></p><p>
+          </p></div></div></div></div></div><div><p class="releaseinfo">Version 0.0.3</p></div><div><div class="abstract"><p class="title"><b>Executive Summary</b></p><p>
OHM is a small open source systems daemon which sits above HAL and
abstracts out common hardware management tasks such as system wide
inhibit action control and controlling heat dissipation on embedded
diff --git a/etc/modules.ini b/etc/modules.ini
index fa3c750..280a4c4 100644
--- a/etc/modules.ini
+++ b/etc/modules.ini
@@ -25,4 +25,4 @@ ModulesSuggested=acadapter;backlight;battery;timeremaining;idle;powerstatus;dpms
# This should list all the modules that are required for coldplug.
# If a required module cannot be loaded, then startup will fail.
# Typically this should be empty, unless you know what you are doing.
-ModulesRequired=
+ModulesRequired=display
diff --git a/ohmd/ohm-plugin.h b/ohmd/ohm-plugin.h
index dbb8f2e..a39ae27 100644
--- a/ohmd/ohm-plugin.h
+++ b/ohmd/ohm-plugin.h
@@ -101,6 +101,7 @@ gboolean ohm_plugin_conf_set_key (OhmPlugin *plugin,
gboolean ohm_plugin_conf_interested (OhmPlugin *plugin,
const gchar *key,
gint id);
+/* used by plugin for hal */
gboolean ohm_plugin_hal_init (OhmPlugin *plugin);
gboolean ohm_plugin_hal_use_property_modified (OhmPlugin *plugin,
OhmPluginHalPropMod func);
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
index a9300c1..c2dc041 100644
--- a/plugins/Makefile.am
+++ b/plugins/Makefile.am
@@ -1,22 +1,6 @@
SUBDIRS = \
- idle \
- battery \
- acadapter \
- timeremaining \
- powerstatus \
- backlight
-
-if HAVE_DPMS_EXTENSION
-SUBDIRS += dpms
-endif
-
-INCLUDES = \
- -I$(top_srcdir)/ohmd \
- $(GLIB_CFLAGS) \
- $(DBUS_CFLAGS) \
- $(GMODULE_CFLAGS) \
- -DPACKAGE_DATA_DIR=\""$(datadir)"\" \
- -DPACKAGE_LOCALE_DIR=\""$(prefix)/$(DATADIRNAME)/locale"\"
+ glue \
+ policy
clean-local:
rm -f *~
diff --git a/plugins/backlight/backlight b/plugins/backlight/backlight
deleted file mode 100644
index ea81817..0000000
--- a/plugins/backlight/backlight
+++ /dev/null
@@ -1,6 +0,0 @@
-# backlight preference values
-backlight.value_ac 100 public
-backlight.value_battery 70 public
-backlight.value_idle 40 public
-backlight.time_idle 200 public
-backlight.time_off 400 public
diff --git a/plugins/glue/Makefile.am b/plugins/glue/Makefile.am
new file mode 100644
index 0000000..bab5d1b
--- /dev/null
+++ b/plugins/glue/Makefile.am
@@ -0,0 +1,14 @@
+SUBDIRS = \
+ idle \
+ battery \
+ acadapter \
+ timeremaining \
+ powerstatus \
+ backlight
+
+if HAVE_DPMS_EXTENSION
+SUBDIRS += dpms
+endif
+
+clean-local:
+ rm -f *~
diff --git a/plugins/acadapter/.gitignore b/plugins/glue/acadapter/.gitignore
index 0ec65bf..0ec65bf 100644
--- a/plugins/acadapter/.gitignore
+++ b/plugins/glue/acadapter/.gitignore
diff --git a/plugins/acadapter/Makefile.am b/plugins/glue/acadapter/Makefile.am
index 4928aee..4928aee 100644
--- a/plugins/acadapter/Makefile.am
+++ b/plugins/glue/acadapter/Makefile.am
diff --git a/plugins/acadapter/README b/plugins/glue/acadapter/README
index 0db68d7..0db68d7 100644
--- a/plugins/acadapter/README
+++ b/plugins/glue/acadapter/README
diff --git a/plugins/acadapter/acadapter b/plugins/glue/acadapter/acadapter
index 3e86554..3e86554 100644
--- a/plugins/acadapter/acadapter
+++ b/plugins/glue/acadapter/acadapter
diff --git a/plugins/acadapter/ohm-plugin-acadapter.c b/plugins/glue/acadapter/ohm-plugin-acadapter.c
index 0c1475e..0c1475e 100644
--- a/plugins/acadapter/ohm-plugin-acadapter.c
+++ b/plugins/glue/acadapter/ohm-plugin-acadapter.c
diff --git a/plugins/backlight/.gitignore b/plugins/glue/backlight/.gitignore
index 0ec65bf..0ec65bf 100644
--- a/plugins/backlight/.gitignore
+++ b/plugins/glue/backlight/.gitignore
diff --git a/plugins/backlight/Makefile.am b/plugins/glue/backlight/Makefile.am
index 48b98b9..48b98b9 100644
--- a/plugins/backlight/Makefile.am
+++ b/plugins/glue/backlight/Makefile.am
diff --git a/plugins/backlight/README b/plugins/glue/backlight/README
index 0db68d7..0db68d7 100644
--- a/plugins/backlight/README
+++ b/plugins/glue/backlight/README
diff --git a/plugins/glue/backlight/backlight b/plugins/glue/backlight/backlight
new file mode 100644
index 0000000..dc652cf
--- /dev/null
+++ b/plugins/glue/backlight/backlight
@@ -0,0 +1,2 @@
+# backlight preference values
+
diff --git a/plugins/backlight/ohm-plugin-backlight.c b/plugins/glue/backlight/ohm-plugin-backlight.c
index e8a732b..c671021 100644
--- a/plugins/backlight/ohm-plugin-backlight.c
+++ b/plugins/glue/backlight/ohm-plugin-backlight.c
@@ -18,12 +18,6 @@
* Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
*/
-/*
- * TODO
- *
- * - Add battery brightness, and detect change in battery state
- */
-
#include <gmodule.h>
#include <glib.h>
@@ -34,26 +28,12 @@
#define HAL_DBUS_INTERFACE_LAPTOP_PANEL "org.freedesktop.Hal.Device.LaptopPanel"
enum {
- CONF_AC_STATE_CHANGED,
- CONF_SYSTEM_IDLE_CHANGED,
- CONF_BRIGHTNESS_AC_CHANGED,
- CONF_BRIGHTNESS_BATTERY_CHANGED,
- CONF_BRIGHTNESS_IDLE_CHANGED,
- CONF_TIME_IDLE_CHANGED,
- CONF_TIME_OFF_CHANGED,
+ CONF_BRIGHTNESS_PERCENT_CHANGED,
+ CONF_BRIGHTNESS_HARDWARE_CHANGED,
CONF_LAST
};
typedef struct {
- gint ac_state;
- gint system_idle;
- gint state;
- gint brightness;
- gint brightness_ac;
- gint brightness_battery;
- gint brightness_idle;
- gint time_idle;
- gint time_off;
gint levels;
} OhmPluginCacheData;
@@ -136,14 +116,10 @@ backlight_get_brightness (OhmPlugin *plugin, guint *brightness)
static gboolean
plugin_preload (OhmPlugin *plugin)
{
- /* FIXME: detect if we have any backlights in the system and return false if not */
- /* add in the required, suggested and prevented plugins */
- ohm_plugin_suggest (plugin, "idle");
- ohm_plugin_suggest (plugin, "acadapter");
-
/* tell ohmd what keys we are going to provide so it can create them */
- ohm_plugin_conf_provide (plugin, "backlight.state");
- ohm_plugin_conf_provide (plugin, "backlight.brightness");
+ ohm_plugin_conf_provide (plugin, "backlight.hardware_brightness");
+ ohm_plugin_conf_provide (plugin, "backlight.percent_brightness");
+ ohm_plugin_conf_provide (plugin, "backlight.num_levels");
return TRUE;
}
@@ -163,45 +139,6 @@ percent_to_discrete (guint percentage,
}
/**
- * check_system_idle_state:
- * @plugin: This class instance
- *
- * Check the idle times, and dim the backlight if required
- */
-static void
-check_system_backlight_state (OhmPlugin *plugin)
-{
- guint hw;
-
- if (data.system_idle > data.time_off) {
- /* turn off screen after 20 seconds */
- data.state = 0;
- data.brightness = 0;
- } else if (data.system_idle > data.time_idle) {
- /* dim screen after 5 seconds */
- data.state = 1;
- data.brightness = data.brightness_idle;
- } else {
- /* set brightness to default value */
- data.state = 1;
- if (data.ac_state == 1) {
- data.brightness = data.brightness_ac;
- } else {
- data.brightness = data.brightness_battery;
- }
- }
- ohm_plugin_conf_set_key (plugin, "backlight.state", data.state);
- ohm_plugin_conf_set_key (plugin, "backlight.brightness", data.brightness);
- g_debug ("setting state %i and brightness %i", data.state, data.brightness);
- if (data.levels == 0) {
- g_warning ("levels zero");
- return;
- }
- hw = percent_to_discrete (data.brightness, data.levels);
- backlight_set_brightness (plugin, hw);
-}
-
-/**
* plugin_coldplug:
* @plugin: This class instance
*
@@ -214,23 +151,9 @@ plugin_coldplug (OhmPlugin *plugin)
{
gboolean ret;
- /* interested keys */
- ohm_plugin_conf_interested (plugin, "acadapter.state", CONF_AC_STATE_CHANGED);
- ohm_plugin_conf_interested (plugin, "idle.system_idle", CONF_SYSTEM_IDLE_CHANGED);
- ohm_plugin_conf_interested (plugin, "backlight.value_ac", CONF_BRIGHTNESS_AC_CHANGED);
- ohm_plugin_conf_interested (plugin, "backlight.value_battery", CONF_BRIGHTNESS_BATTERY_CHANGED);
- ohm_plugin_conf_interested (plugin, "backlight.value_idle", CONF_BRIGHTNESS_IDLE_CHANGED);
- ohm_plugin_conf_interested (plugin, "backlight.time_idle", CONF_TIME_IDLE_CHANGED);
- ohm_plugin_conf_interested (plugin, "backlight.time_off", CONF_TIME_OFF_CHANGED);
-
- /* preference values */
- ohm_plugin_conf_get_key (plugin, "acadapter.state", &(data.ac_state));
- ohm_plugin_conf_get_key (plugin, "idle.system_idle", &(data.system_idle));
- ohm_plugin_conf_get_key (plugin, "backlight.value_ac", &(data.brightness_ac));
- ohm_plugin_conf_get_key (plugin, "backlight.value_battery", &(data.brightness_battery));
- ohm_plugin_conf_get_key (plugin, "backlight.value_idle", &(data.brightness_idle));
- ohm_plugin_conf_get_key (plugin, "backlight.time_idle", &(data.time_idle));
- ohm_plugin_conf_get_key (plugin, "backlight.time_off", &(data.time_off));
+ /* interested keys, either can be changed without changing the other */
+ ohm_plugin_conf_interested (plugin, "backlight.hardware_brightness", CONF_BRIGHTNESS_HARDWARE_CHANGED);
+ ohm_plugin_conf_interested (plugin, "backlight.percent_brightness", CONF_BRIGHTNESS_PERCENT_CHANGED);
/* initialise HAL */
ohm_plugin_hal_init (plugin);
@@ -246,8 +169,11 @@ plugin_coldplug (OhmPlugin *plugin)
/* get levels that the adapter supports -- this does not change ever */
ohm_plugin_hal_get_int (plugin, "laptop_panel.num_levels", &data.levels);
-
- check_system_backlight_state (plugin);
+ if (data.levels == 0) {
+ g_error ("levels zero!");
+ return;
+ }
+ ohm_plugin_conf_set_key (plugin, "backlight.num_levels", data.levels);
}
/**
@@ -261,33 +187,19 @@ plugin_coldplug (OhmPlugin *plugin)
static void
plugin_conf_notify (OhmPlugin *plugin, gint id, gint value)
{
- if (id == CONF_SYSTEM_IDLE_CHANGED) {
- data.system_idle = value;
- check_system_backlight_state (plugin);
- } else if (id == CONF_AC_STATE_CHANGED) {
- data.ac_state = value;
- check_system_backlight_state (plugin);
- } else if (id == CONF_BRIGHTNESS_AC_CHANGED) {
- data.brightness_ac = value;
- check_system_backlight_state (plugin);
- } else if (id == CONF_BRIGHTNESS_BATTERY_CHANGED) {
- data.brightness_battery = value;
- check_system_backlight_state (plugin);
- } else if (id == CONF_BRIGHTNESS_IDLE_CHANGED) {
- data.brightness_idle = value;
- check_system_backlight_state (plugin);
- } else if (id == CONF_TIME_IDLE_CHANGED) {
- data.time_idle = value;
- check_system_backlight_state (plugin);
- } else if (id == CONF_TIME_OFF_CHANGED) {
- data.time_off = value;
- check_system_backlight_state (plugin);
+ guint hw;
+ if (id == CONF_BRIGHTNESS_PERCENT_CHANGED) {
+ hw = percent_to_discrete (value, data.levels);
+ ohm_plugin_conf_set_key (plugin, "backlight.hardware_brightness", hw);
+ // backlight_set_brightness (plugin, hw); ------ SHOULDN'T BE NEEDED
+ } else if (id == CONF_BRIGHTNESS_HARDWARE_CHANGED) {
+ backlight_set_brightness (plugin, value);
}
}
static OhmPluginInfo plugin_info = {
"OHM Backlight", /* description */
- "0.0.1", /* version */
+ "0.0.2", /* version */
"richard@hughsie.com", /* author */
plugin_preload, /* preload */
NULL, /* unload */
diff --git a/plugins/battery/.gitignore b/plugins/glue/battery/.gitignore
index 0ec65bf..0ec65bf 100644
--- a/plugins/battery/.gitignore
+++ b/plugins/glue/battery/.gitignore
diff --git a/plugins/battery/Makefile.am b/plugins/glue/battery/Makefile.am
index 55d03cc..55d03cc 100644
--- a/plugins/battery/Makefile.am
+++ b/plugins/glue/battery/Makefile.am
diff --git a/plugins/battery/README b/plugins/glue/battery/README
index 0db68d7..0db68d7 100644
--- a/plugins/battery/README
+++ b/plugins/glue/battery/README
diff --git a/plugins/battery/battery b/plugins/glue/battery/battery
index ed1b869..ed1b869 100644
--- a/plugins/battery/battery
+++ b/plugins/glue/battery/battery
diff --git a/plugins/battery/ohm-plugin-battery.c b/plugins/glue/battery/ohm-plugin-battery.c
index da979be..da979be 100644
--- a/plugins/battery/ohm-plugin-battery.c
+++ b/plugins/glue/battery/ohm-plugin-battery.c
diff --git a/plugins/dpms/.gitignore b/plugins/glue/dpms/.gitignore
index 0ec65bf..0ec65bf 100644
--- a/plugins/dpms/.gitignore
+++ b/plugins/glue/dpms/.gitignore
diff --git a/plugins/dpms/Makefile.am b/plugins/glue/dpms/Makefile.am
index 9c2525d..9c2525d 100644
--- a/plugins/dpms/Makefile.am
+++ b/plugins/glue/dpms/Makefile.am
diff --git a/plugins/dpms/README b/plugins/glue/dpms/README
index 0db68d7..0db68d7 100644
--- a/plugins/dpms/README
+++ b/plugins/glue/dpms/README
diff --git a/plugins/dpms/dpms b/plugins/glue/dpms/dpms
index d06aacf..d06aacf 100644
--- a/plugins/dpms/dpms
+++ b/plugins/glue/dpms/dpms
diff --git a/plugins/dpms/ohm-plugin-dpms.c b/plugins/glue/dpms/ohm-plugin-dpms.c
index 8810865..8810865 100644
--- a/plugins/dpms/ohm-plugin-dpms.c
+++ b/plugins/glue/dpms/ohm-plugin-dpms.c
diff --git a/plugins/idle/.gitignore b/plugins/glue/idle/.gitignore
index 0ec65bf..0ec65bf 100644
--- a/plugins/idle/.gitignore
+++ b/plugins/glue/idle/.gitignore
diff --git a/plugins/idle/Makefile.am b/plugins/glue/idle/Makefile.am
index c4af154..c4af154 100644
--- a/plugins/idle/Makefile.am
+++ b/plugins/glue/idle/Makefile.am
diff --git a/plugins/idle/README b/plugins/glue/idle/README
index 0db68d7..0db68d7 100644
--- a/plugins/idle/README
+++ b/plugins/glue/idle/README
diff --git a/plugins/idle/idle b/plugins/glue/idle/idle
index 61f8f33..61f8f33 100644
--- a/plugins/idle/idle
+++ b/plugins/glue/idle/idle
diff --git a/plugins/idle/ohm-plugin-idle.c b/plugins/glue/idle/ohm-plugin-idle.c
index 56d178b..56d178b 100644
--- a/plugins/idle/ohm-plugin-idle.c
+++ b/plugins/glue/idle/ohm-plugin-idle.c
diff --git a/plugins/powerstatus/.gitignore b/plugins/glue/powerstatus/.gitignore
index 0ec65bf..0ec65bf 100644
--- a/plugins/powerstatus/.gitignore
+++ b/plugins/glue/powerstatus/.gitignore
diff --git a/plugins/powerstatus/Makefile.am b/plugins/glue/powerstatus/Makefile.am
index a948c44..a948c44 100644
--- a/plugins/powerstatus/Makefile.am
+++ b/plugins/glue/powerstatus/Makefile.am
diff --git a/plugins/powerstatus/README b/plugins/glue/powerstatus/README
index 0db68d7..0db68d7 100644
--- a/plugins/powerstatus/README
+++ b/plugins/glue/powerstatus/README
diff --git a/plugins/powerstatus/ohm-plugin-powerstatus.c b/plugins/glue/powerstatus/ohm-plugin-powerstatus.c
index d07fdf7..d07fdf7 100644
--- a/plugins/powerstatus/ohm-plugin-powerstatus.c
+++ b/plugins/glue/powerstatus/ohm-plugin-powerstatus.c
diff --git a/plugins/powerstatus/powerstatus b/plugins/glue/powerstatus/powerstatus
index d3814e5..d3814e5 100644
--- a/plugins/powerstatus/powerstatus
+++ b/plugins/glue/powerstatus/powerstatus
diff --git a/plugins/timeremaining/.gitignore b/plugins/glue/timeremaining/.gitignore
index 0ec65bf..0ec65bf 100644
--- a/plugins/timeremaining/.gitignore
+++ b/plugins/glue/timeremaining/.gitignore
diff --git a/plugins/timeremaining/Makefile.am b/plugins/glue/timeremaining/Makefile.am
index c1af09b..c1af09b 100644
--- a/plugins/timeremaining/Makefile.am
+++ b/plugins/glue/timeremaining/Makefile.am
diff --git a/plugins/timeremaining/README b/plugins/glue/timeremaining/README
index 0db68d7..0db68d7 100644
--- a/plugins/timeremaining/README
+++ b/plugins/glue/timeremaining/README
diff --git a/plugins/timeremaining/ohm-plugin-timeremaining.c b/plugins/glue/timeremaining/ohm-plugin-timeremaining.c
index 7756b5d..7756b5d 100644
--- a/plugins/timeremaining/ohm-plugin-timeremaining.c
+++ b/plugins/glue/timeremaining/ohm-plugin-timeremaining.c
diff --git a/plugins/timeremaining/timeremaining b/plugins/glue/timeremaining/timeremaining
index 6b8a282..6b8a282 100644
--- a/plugins/timeremaining/timeremaining
+++ b/plugins/glue/timeremaining/timeremaining