summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Taylor <rob.taylor@codethink.co.uk>2007-09-23 18:08:18 +0200
committerRob Taylor <rob.taylor@codethink.co.uk>2007-09-23 18:08:18 +0200
commit8a8d756947470fb6e7c666e58be729b536b06834 (patch)
treee6478a33c2c44850d60527678100bf16872087d2
parentf4908f9a2508e79a1e58fb6c08f602f4cbccb97d (diff)
Install custom modules.ini
Install custom modules.ini in debian package.
-rw-r--r--debian/changelog6
-rw-r--r--debian/modules.ini28
-rwxr-xr-xdebian/rules3
3 files changed, 37 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index fe31976..95c1ce5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+ohm (0.1.1-3) experimental; urgency=low
+
+ * Install custom modules.ini
+
+ -- Rob Taylor <rob.taylor@codethink.co.uk> Thu, 13 Sep 2007 15:30:17 +0100
+
ohm (0.1.1-2) experimental; urgency=low
* build --without-xauth
diff --git a/debian/modules.ini b/debian/modules.ini
new file mode 100644
index 0000000..bf2b4be
--- /dev/null
+++ b/debian/modules.ini
@@ -0,0 +1,28 @@
+# The OHM system modules configuration file
+#
+# Only the system target designer should modify this file, ordinary users
+# should not have to change anything.
+
+[Modules]
+
+# If we should perform additional checks on the modules
+# Turning this to false increasing performance if the device target is fixed
+# and OHM is known to work correctly without errors.
+# If you are developing with OHM, this should be true.
+PerformExtraChecks=true
+
+# This should list all the modules that are banned, i.e. will not be loaded.
+# If a loaded module requires a banned module, then startup will fail.
+# Typically this should be empty, unless you know what you are doing.
+ModulesBanned=embedded
+
+# This file should list all the modules that are suggested for coldplug.
+# If a suggested module is not present, then startup will not fail.
+# Typically this should contain modules most likely to be used on the system
+# OHM is targeted for. Order is unimportant, separate entries with ';'.
+ModulesSuggested=acadapter;backlight;battery;timeremaining;idle;powerstatus;dpms;buttons;xorg
+
+# This should list all the modules that are required for coldplug.
+# If a required module cannot be loaded, then startup will fail.
+# Typically this should be empty, unless you know what you are doing.
+ModulesRequired=display;timeouts
diff --git a/debian/rules b/debian/rules
index 514b0a6..fa0020a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -11,3 +11,6 @@ DEB_CONFIGURE_EXTRA_FLAGS := --without-xauth \
--enable-gtk-doc
DEB_DH_INSTALL_ARGS := --sourcedir=debian/tmp
+
+install/ohm::
+ cp debian/modules.ini debian/tmp/etc/ohm/modules.ini