summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 1 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index c7245dda..15a1d405 100644
--- a/meson.build
+++ b/meson.build
@@ -256,15 +256,13 @@ foreach t : [[with_intel, 'INTEL'], [with_vmwgfx, 'VMWGFX'],
[with_exynos, 'EXYNOS'],
[with_vc4, 'VC4'],
[with_freedreno_kgsl, 'FREEDRENO_KGSL'],
+ [dep_cairo.found(), 'CAIRO'],
[with_radeon, 'RADEON']]
config.set10('HAVE_@0@'.format(t[1]), t[0])
endforeach
if with_freedreno_kgsl and not with_freedreno
error('cannot enable freedreno-kgsl without freedreno support')
endif
-if dep_cairo.found()
- config.set10('HAVE_CAIRO', true)
-endif
if dep_valgrind.found()
config.set10('HAVE_VALGRIND', true)
endif