summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPranav Kant <pranavk@collabora.co.uk>2016-12-15 15:26:54 +0530
committerPranav Kant <pranavk@collabora.co.uk>2016-12-15 16:52:07 +0530
commit39dd5018e255ad529b409218cff983690700d70d (patch)
tree6b2fbb5b73f628ca0cfb4edb3bed85598e97a3ba /configure.ac
parent6c4472de1d056bdb1a5463d7402e006ecec6880f (diff)
browser console logging depending on loleaflet_logging prop.
loleaflet_logging defaults to true with compiled with --enable-debug otherwise false. Browser will print additional debug info when this property is set to true. Change-Id: Id9fabf134bd8d19fa1a09ca8c0987df46d4f1a4c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index fd0b0f626..5655aa0b2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -109,6 +109,7 @@ ENABLE_DEBUG=
LOOLWSD_LOGLEVEL="warning"
LOOLWSD_LOG_TO_FILE="false"
LOOLWSD_LOGFILE="/var/log/loolwsd.log"
+LOLEAFLET_LOGGING="false"
debug_msg="secure mode: product build"
if test "$enable_debug" = "yes"; then
AC_DEFINE([ENABLE_DEBUG],1,[Whether to compile in some extra debugging support code and disable some security pieces])
@@ -116,6 +117,7 @@ if test "$enable_debug" = "yes"; then
LOOLWSD_LOGLEVEL="trace"
LOOLWSD_LOG_TO_FILE="true"
LOOLWSD_LOGFILE="/tmp/loolwsd.log"
+ LOLEAFLET_LOGGING="true"
debug_msg="low security debugging mode"
else
AC_DEFINE([ENABLE_DEBUG],0,[Whether to compile in some extra debugging support code and disable some security pieces])
@@ -123,6 +125,7 @@ fi
AC_SUBST(ENABLE_DEBUG)
AC_SUBST(LOOLWSD_LOGLEVEL)
AC_SUBST(LOOLWSD_LOG_TO_FILE)
+AC_SUBST(LOLEAFLET_LOGGING)
if test -n "$with_logfile" ; then
LOOLWSD_LOGFILE="$with_logfile"
@@ -324,4 +327,3 @@ echo " \$ make run # to start loolwsd
fi
dnl vim:set shiftwidth=4 softtabstop=4 expandtab:
-