summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2018-08-31 13:24:17 +0300
committerTor Lillqvist <tml@collabora.com>2018-09-03 17:10:19 +0300
commit1ae4a32067c5e1892e47434fb94c7c1f224b7830 (patch)
tree6da2fdc236363406a869855e39d97fd0bcab8a0b /Makefile.am
parent8085b112dc13a676a54e0aeca47e9b792d68fcf1 (diff)
Factor out loleaflet/dist construction for iOS app building
The idea is that on a Linux box you have a tree of online that you configure with --enable-iosapp. Then running 'make' there will only create the stuff in loleaflet/dist. That loleaflet/dist can then be copied to the Mac where you build the iOS app. (To me, this approach seemed for now simpler than to get all the PKG_CONFIG etc stuff working that running configure normally requires, and run all the node, npm, and associated crack, on a Mac.) Change-Id: Id2e495d0521922d0666fdab5fdcb5fcd460136f1
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a8901de71..141467a5e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,3 +1,9 @@
+if ENABLE_IOSAPP
+
+SUBDIRS = loleaflet
+
+else
+
SUBDIRS = . test loleaflet
export ENABLE_DEBUG
@@ -357,3 +363,5 @@ endif
# just run the build without any tests
build-nocheck: all-am
+
+endif