summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMiklos Vajna <vmiklos@collabora.co.uk>2014-12-10 22:15:21 +0100
committerMiklos Vajna <vmiklos@collabora.co.uk>2014-12-10 22:15:21 +0100
commitabdc998562acac7174ac8f83935404456109a141 (patch)
tree787f6040863e3b63a0bc48ef16507cf1344dddf7 /configure.ac
parent109540e113867fd140838e5be79ca0e41c13d85c (diff)
fdo#86664 VSDX: test metadata import
Only title as a start. Change-Id: I6d5f6e2dc1730ff2b2dfda760d575f605ab034eb
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d279ec1..41e3d7e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -306,6 +306,21 @@ AS_IF([test "x$enable_debug" = "xyes"], [
])
AC_SUBST(DEBUG_CXXFLAGS)
+# ==========
+# Unit tests
+# ==========
+AC_ARG_ENABLE([tests],
+ [AS_HELP_STRING([--enable-tests], [Build and run unit tests])],
+ [enable_tests="$enableval"],
+ [enable_tests=yes]
+)
+AS_IF([test "x$enable_tests" = "xyes"], [
+ PKG_CHECK_MODULES([CPPUNIT], [cppunit])
+], [])
+AC_SUBST([CPPUNIT_CFLAGS])
+AC_SUBST([CPPUNIT_LIBS])
+AM_CONDITIONAL([ENABLE_TESTS], [test "x$enable_tests" = "xyes"])
+
# =============
# Documentation
# =============
@@ -342,6 +357,7 @@ src/conv/text/vsd2text.rc
src/conv/text/vss2text.rc
src/lib/Makefile
src/lib/libvisio.rc
+src/test/Makefile
inc/Makefile
inc/libvisio/Makefile
build/Makefile
@@ -360,6 +376,7 @@ AC_MSG_NOTICE([
Build configuration:
debug: ${enable_debug}
docs: ${build_docs}
+ tests: ${enable_tests}
tools: ${enable_tools}
werror: ${enable_werror}
==============================================================================