summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFridrich Štrba <fridrich.strba@bluewin.ch>2012-09-25 13:56:18 +0200
committerFridrich Štrba <fridrich.strba@bluewin.ch>2012-09-25 16:30:08 +0200
commit0fb0421ba6f724e3b9334f41f923a7b2950b40e0 (patch)
tree6dae8accbfbb72e123f695bceb5c15bb0bd0be31 /configure.ac
parent0288a2d8ac36ba0694b2fcce200e6b0122ff8617 (diff)
Setting up a hash framework for intelligent work with xml tokens
requires gperf >= 3.0.0 at build time
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a0b5ed4..362f124 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,6 +34,23 @@ AC_PROG_LIBTOOL
AC_LIBTOOL_WIN32_DLL
PKG_PROG_PKG_CONFIG([0.20])
+AC_PROG_EGREP
+
+dnl ===================================================================
+dnl Check for gperf
+dnl ===================================================================
+AC_PATH_PROG(GPERF, gperf)
+if test -z "$GPERF"; then
+ AC_MSG_ERROR([gperf not found but needed. Install it.])
+fi
+AC_MSG_CHECKING([gperf version])
+if test "`$GPERF --version | $EGREP ^GNU\ gperf | $AWK '{ print $3 }' | cut -d. -f1`" -ge "3"; then
+ AC_MSG_RESULT([OK])
+else
+ AC_MSG_ERROR([too old, you need at least 3.0.0])
+fi
+AC_SUBST(GPERF)
+
# ====================
# Find additional apps
# ====================