summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTomas Chvatal <tchvatal@suse.cz>2011-08-22 19:37:02 +0200
committerTibby Lickle <tibbylickle@gmail.com>2011-08-26 13:14:11 +0100
commitae586b219b24c7d5d4f0aa88852c2c01d84b2463 (patch)
treed5a7ee625899772ac48331f50b846b267a307713 /configure.ac
parent78aec920118c3d1648089aa45ec51ee3e8a62734 (diff)
Set silent rules properly. Fix dummy_bitmaps check.
Signed-off-by: Tomas Chvatal <tchvatal@suse.cz> Signed-off-by: Tibby Lickle <tibbylickle@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index c18e937..eaf7b32 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,7 +20,7 @@ AC_INIT([libvisio],[libvisio_version])
AC_CONFIG_MACRO_DIR([m4])
AM_CONFIG_HEADER([config.h])
AM_INIT_AUTOMAKE([1.11 foreign dist-xz dist-bzip2])
-m4_define([AM_SILENT_RULES])
+AM_SILENT_RULES([yes])
AC_LANG([C++])
# ===========================
@@ -172,8 +172,8 @@ AM_CONDITIONAL(STATIC_TOOLS, [test "x$enable_static_tools" = "xyes"])
AC_ARG_WITH(dummy_bitmaps,
[AS_HELP_STRING([--with-dummy-bitmaps],
[Output dummy bitmaps of 1x1 pixels instead of the real bitmaps (speeds up the validation test)])],
- [enable_dummy_bitmaps="$enableval"],
- [enable_dummy_bitmaps=no]
+ [with_dummy_bitmaps="$withval"],
+ [with_dummy_bitmaps=no]
)
AM_CONDITIONAL([OUTPUT_DUMMY_BITMAPS], [test "x$with_dummy_bitmaps" = "xyes"])
@@ -182,7 +182,7 @@ AM_CONDITIONAL([OUTPUT_DUMMY_BITMAPS], [test "x$with_dummy_bitmaps" = "xyes"])
# =============
AC_ARG_WITH(docs,
[AS_HELP_STRING([--without-docs], [Do not build documentation])],
- [with_docs="$enableval"],
+ [with_docs="$withval"],
[AS_IF([test "x$native_win32" = "xyes"], [with_docs=no], [with_docs=yes])]
)
AS_IF([test "x$with_docs" != "xno"], [
@@ -226,7 +226,7 @@ AC_MSG_NOTICE([
Build configuration:
debug: ${enable_debug}
docs: ${build_docs}
- dummy-bitmaps: ${enable_dummy_bitmaps}
+ dummy-bitmaps: ${with_dummy_bitmaps}
static-tools: ${enable_static_tools}
werror: ${enable_werror}
==============================================================================