summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorFridrich Štrba <fridrich.strba@bluewin.ch>2011-05-17 10:59:34 +0200
committerFridrich Štrba <fridrich.strba@bluewin.ch>2011-05-17 10:59:34 +0200
commitb30ffe08194f5b1573ba7ce101dea356bb9fdb54 (patch)
treeac53b1e725aa41ee81489c3aa0053f897f8106f8 /Makefile.am
Initial skeleton of libvisio
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..1956bb2
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,30 @@
+pkgconfdir = $(libdir)/pkgconfig
+
+pkgconf_DATA = libvisio-@VSD_MAJOR_VERSION@.@VSD_MINOR_VERSION@.pc
+
+SUBDIRS = src build docs
+
+EXTRA_DIST = \
+ AUTHORS \
+ COPYING \
+ NEWS \
+ README \
+ autogen.sh \
+ libvisio-@VSD_MAJOR_VERSION@.@VSD_MINOR_VERSION@.pc.in \
+ libvisio-zip.in \
+ libvisio.spec \
+ libvisio.spec.in
+
+distclean-local:
+ rm -rf *.cache *~
+
+rpm: dist
+ rpmbuild -ta $(PACKAGE)-$(VERSION).tar.gz
+ @rm -f $(PACKAGE)-$(VERSION).tar.gz
+
+zip: all install
+ sh libvisio-zip
+
+dist-hook:
+ git log --date=short --pretty="format:@%cd %an <%ae> [%H]%n%n%s%n%n%e%b" | sed -e "s|^\([^@]\)|\t\1|" -e "s|^@||" >$(distdir)/ChangeLog
+