summaryrefslogtreecommitdiff
path: root/src/qmicli/test/Makefile.am
diff options
context:
space:
mode:
authorAleksander Morgado <aleksander@aleksander.es>2018-01-10 22:40:47 +0100
committerAleksander Morgado <aleksander@aleksander.es>2018-01-10 22:40:56 +0100
commit0cee0bdf6d9b1d5bf03c6310294369a9de159038 (patch)
tree67a9334f886154f5d5a26028159f69a2fc67290b /src/qmicli/test/Makefile.am
parentcc8587fa012aa6f65e6c47a5a2b8e37d79a9c004 (diff)
build: don't build qmicli-helpers twice
Build them once in a single non-inst library.
Diffstat (limited to 'src/qmicli/test/Makefile.am')
-rw-r--r--src/qmicli/test/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/src/qmicli/test/Makefile.am b/src/qmicli/test/Makefile.am
index b07281e..01dd311 100644
--- a/src/qmicli/test/Makefile.am
+++ b/src/qmicli/test/Makefile.am
@@ -6,9 +6,7 @@ noinst_PROGRAMS = \
TEST_PROGS += $(noinst_PROGRAMS)
test_helpers_SOURCES = \
- test-helpers.c \
- $(top_srcdir)/src/qmicli/qmicli-helpers.h \
- $(top_srcdir)/src/qmicli/qmicli-helpers.c
+ test-helpers.c
test_helpers_CPPFLAGS = \
$(GLIB_CFLAGS) \
@@ -21,4 +19,5 @@ test_helpers_CPPFLAGS = \
test_helpers_LDADD = \
$(GLIB_LIBS) \
+ $(top_builddir)/src/qmicli/libhelpers.la \
$(top_builddir)/src/libqmi-glib/libqmi-glib.la