summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 18 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 42b0cf94..cedcb226 100644
--- a/configure.in
+++ b/configure.in
@@ -100,6 +100,21 @@ fi
AC_SUBST(ACPI_PROC)
AM_CONDITIONAL(ACPI_PROC, test x$acpi_proc = xyes)
+
+dnl libparted
+AC_ARG_ENABLE([parted], AC_HELP_STRING([--enable-parted], [Use libparted]), [use_parted=$enableval], [use_parted=no])
+if test "x$use_parted" = "xyes" ; then
+ USE_PARTED=yes
+ AC_DEFINE(USE_PARTED,1,[Whether libparted is to be used])
+ PARTED_CHECK_LIBPARTED(1.7.1, ,
+ [AC_MSG_ERROR([*** libparted >= 1.7.1 not installed - please install first ***])])
+else
+ USE_PARTED=no
+fi
+AC_SUBST(USE_PARTED)
+AM_CONDITIONAL(USE_PARTED, test x$use_parted == xyes)
+
+
#### gcc warning flags
if test "x$GCC" = "xyes"; then
@@ -184,7 +199,7 @@ AM_CONDITIONAL(GCOV, test x$enable_gcov = xyes)
EXPAT_LIB=""
-AC_ARG_WITH(expat, [ --with-expat=<dir> ese expat from here],
+AC_ARG_WITH(expat, [ --with-expat=<dir> Use expat from here],
[
expat=$withval
CPPFLAGS="$CPPFLAGS -I$withval/include"
@@ -457,6 +472,7 @@ tools/linux/Makefile
tools/device-manager/hal-device-manager
tools/device-manager/Makefile
tools/device-manager/Const.py
+partutil/Makefile
privileges/Makefile
fdi/Makefile
fdi/preprobe/Makefile
@@ -510,6 +526,7 @@ echo "
use acpid interface: ${acpi_acpid}
use libusb: ${USE_LIBUSB}
use libpci: ${USE_LIBPCI}
+ use libparted: ${USE_PARTED}
use PolicyKit: ${msg_polkit}