summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRichard Hughes <richard@hughsie.com>2007-06-11 16:32:18 +0100
committerRichard Hughes <richard@hughsie.com>2007-06-11 16:32:18 +0100
commite7b7241a92149429a9e74a01f83c7fcce585f5ce (patch)
tree7217ef1ab6a158f880c1e5e73fafca0014f3c752 /configure.in
parenta492453b15abfbaada99e1fd51a516acb480331d (diff)
fix build when gperf is not installed
Make still tries to rebuild the .h file, even when present. If gperf is not installed, don't let make even _try_ to rebuild the file.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index cd8c80c2..0b6734c3 100644
--- a/configure.in
+++ b/configure.in
@@ -658,6 +658,16 @@ else
have_xmllint=yes
fi
+AC_PATH_PROG(GPERF, [gperf], [no])
+AC_MSG_CHECKING([whether to rebuild gperf header files])
+if test x$GPERF = xno ; then
+ have_gperf=no
+else
+ have_gperf=yes
+fi
+AC_SUBST(HAVE_GPERF)
+AM_CONDITIONAL(HAVE_GPERF, [test x$have_gperf = xyes])
+
if test x$enable_docbook_docs = xauto ; then
if test x$have_xmlto = xno || test x$have_xmllint = xno ; then
enable_docbook_docs=no