summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGeorge Kiagiadakis <george.kiagiadakis@collabora.com>2013-05-23 20:52:43 +0300
committerGeorge Kiagiadakis <george.kiagiadakis@collabora.com>2013-06-05 11:58:43 +0300
commita821ae1c6c005f0745b4b0cb9b6d8aeb270ada88 (patch)
tree465e68385f0b06d0c917889767d1f7f28adf23a7 /CMakeLists.txt
parent5bad049fd2192b6b00abde485f6e8171d68ca933 (diff)
qt5: Rename the libraries and the package when building with qt5
This is to keep the libraries co-installable with the qt4 versions
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 14 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1a1d8d5..540cae8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,10 +41,19 @@ macro_log_feature(Boost_FOUND "Boost" "Required for building QtGLib" "http://www
# set the QTGSTREAMER_* cmake variables
set(BUILDING_QTGSTREAMER TRUE)
-set(QTGLIB_LIBRARY QtGLib)
-set(QTGSTREAMER_LIBRARY QtGStreamer)
-set(QTGSTREAMER_UI_LIBRARY QtGStreamerUi)
-set(QTGSTREAMER_UTILS_LIBRARY QtGStreamerUtils)
+if (USE_QT5)
+ set(QTGLIB_LIBRARY Qt5GLib)
+ set(QTGSTREAMER_LIBRARY Qt5GStreamer)
+ set(QTGSTREAMER_UI_LIBRARY Qt5GStreamerUi)
+ set(QTGSTREAMER_UTILS_LIBRARY Qt5GStreamerUtils)
+ set(QTGSTREAMER_PACKAGE_NAME Qt5GStreamer)
+elseif (USE_QT4)
+ set(QTGLIB_LIBRARY QtGLib)
+ set(QTGSTREAMER_LIBRARY QtGStreamer)
+ set(QTGSTREAMER_UI_LIBRARY QtGStreamerUi)
+ set(QTGSTREAMER_UTILS_LIBRARY QtGStreamerUtils)
+ set(QTGSTREAMER_PACKAGE_NAME QtGStreamer)
+endif()
set(QTGSTREAMER_INCLUDE_DIR ${CMAKE_SOURCE_DIR}/src)
include(QtGStreamerConfigCommon)
@@ -106,7 +115,7 @@ if (CMAKE_COMPILER_IS_GNUCXX)
endif ()
set(LIB_INSTALL_DIR ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX} CACHE STRING "Destination directory for libraries")
-set(INCLUDES_INSTALL_DIR ${CMAKE_INSTALL_PREFIX}/include/QtGStreamer)
+set(INCLUDES_INSTALL_DIR ${CMAKE_INSTALL_PREFIX}/include/${QTGSTREAMER_PACKAGE_NAME})
if (USE_GST_PLUGIN_DIR)
set(PLUGINS_INSTALL_DIR ${GSTREAMER_PLUGIN_DIR})