summaryrefslogtreecommitdiff
path: root/pkgconfig/Makefile.am
diff options
context:
space:
mode:
authorGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2017-01-04 16:20:54 +0100
committerThibault Saunier <thibault.saunier@osg.samsung.com>2017-01-05 09:42:29 -0300
commite6c6bf96ce7d3240b5343c52ff6218a323258781 (patch)
treec177ca19c6a51bf5e8202903f147ede6e29eef0f /pkgconfig/Makefile.am
parent3a911a2f58002e3e2a99031d19b37bc1161c49c8 (diff)
meson: generate pkg-config -uninstalled pc files
Generating those files is useful for users building the GStreamer stack using meson and having to link it to another project which is still using the autotools. https://bugzilla.gnome.org/show_bug.cgi?id=776810
Diffstat (limited to 'pkgconfig/Makefile.am')
-rw-r--r--pkgconfig/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/pkgconfig/Makefile.am b/pkgconfig/Makefile.am
index c45755e..cf36182 100644
--- a/pkgconfig/Makefile.am
+++ b/pkgconfig/Makefile.am
@@ -10,7 +10,11 @@ all-local: $(pcfiles) $(pcfiles_uninstalled)
%-@GST_API_VERSION@.pc: %.pc
cp $< $@
%-@GST_API_VERSION@-uninstalled.pc: %-uninstalled.pc
- cp $< $@
+### the uninstalled libdir is depend of the build system used so set it here
+### rather than hardcoding it in the file directly.
+ $(AM_V_GEN) sed \
+ -e "s|[@]rtspserverlibdir[@]|$(abs_top_builddir)/gst/rtsp-server/.libs|" \
+ $< > $@.tmp && mv $@.tmp $@
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = $(pcfiles)