summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWim Taymans <wtaymans@redhat.com>2014-03-13 17:35:21 +0100
committerWim Taymans <wtaymans@redhat.com>2014-03-25 10:31:21 +0100
commit3d6175c745997c3126acc8c563ff18978966f245 (patch)
tree52e64361cfcf43d2671ef22be752a73375eabaf8 /configure.ac
parentbfbf393925643f1c5c9b17d9cc5331f23ba321ec (diff)
stream: add SRTP support
Install srtp encoder and decoder elements in rtpbin Add MIKEY in SDP
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4b12b26..9f61fc7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,6 +59,7 @@ dnl *** required versions of GStreamer stuff ***
GST_REQ=1.3.0.1
GSTPB_REQ=1.3.0.1
GSTPG_REQ=1.3.0.1
+GSTPD_REQ=1.3.0.1
dnl *** autotools stuff ****
@@ -176,6 +177,11 @@ GSTPG_PLUGINS_DIR=`$PKG_CONFIG gstreamer-plugins-good-$GST_API_VERSION --variabl
AC_SUBST(GSTPG_PLUGINS_DIR)
AC_MSG_NOTICE(Using GStreamer Good Plugins in $GSTPG_PLUGINS_DIR)
+AG_GST_CHECK_GST_PLUGINS_BAD($GST_API_VERSION, [$GSTPD_REQ], [yes])
+GSTPD_PLUGINS_DIR=`$PKG_CONFIG gstreamer-plugins-bad-$GST_API_VERSION --variable pluginsdir`
+AC_SUBST(GSTPD_PLUGINS_DIR)
+AC_MSG_NOTICE(Using GStreamer Bad Plugins in $GSTPD_PLUGINS_DIR)
+
AG_GST_CHECK_GST_CHECK($GST_API_VERSION, [$GST_REQ], no)
AM_CONDITIONAL(HAVE_CHECK, test "x$HAVE_GST_CHECK" = "xyes")