summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid I. Lehn <dlehn@users.sourceforge.net>2004-02-03 09:45:42 +0000
committerDavid I. Lehn <dlehn@users.sourceforge.net>2004-02-03 09:45:42 +0000
commitc71d66dbdedb40193c2170ee04d332fe2ed48fbe (patch)
treeaf9e098fb58a8be1ed8e2e5959308392e5b2e07f /Makefile.am
parent11e199b27c962389e45b07a733ec1a3bb1ecd322 (diff)
gst/: Support GstPlay, bug fixes, updates.
Original commit message from CVS: * gstinterfaces/.cvsignore: * gstinterfaces/0.7.defs: * gstinterfaces/Makefile.am: * gstinterfaces/common.defs: * gstinterfaces/common.override: * gstinterfaces/gstinterfacesmodule.c: (init_gstinterfaces): * gstplay/.cvsignore: * gstplay/0.7.c: * gstplay/0.7.defs: * gstplay/0.7.h: * gstplay/0.7.override: * gstplay/Makefile.am: * gstplay/__init__.py: * gstplay/arg-types.py: * gstplay/common.c: * gstplay/common.h: * gstplay/common.override: * gstplay/gstplaymodule.c: (init_gstplay): * gstreamer/Makefile.am: * gstreamer/__init__.py: * gstreamer/common.override: Support GstPlay, bug fixes, updates. * examples/gstplay/player.py: GstPlay example. * Makefile.am: Support GstPlay build. * configure.ac: Support GstPlay build, remove AC_SUBST() calls that PKG_CHECK_MODULES does automagically.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 5126195..d7f2064 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,13 +6,19 @@ endif
if GST_0_6
INTERFACESDIR =
+PLAYDIR =
else
INTERFACESDIR = gstinterfaces
+PLAYDIR = gstplay
endif
UNCONDDIRS = gstreamer pkgconfig examples testsuite
-SUBDIRS = $(UNCONDDIRS) $(SUBDIRS_DOCS) $(INTERFACESDIR)
-DIST_SUBDIRS = $(UNCONDDIRS) docs gstinterfaces
+SUBDIRS = \
+ $(UNCONDDIRS) \
+ $(INTERFACESDIR) \
+ $(PLAYDIR) \
+ $(SUBDIRS_DOCS)
+DIST_SUBDIRS = $(UNCONDDIRS) docs gstinterfaces gstplay
EXTRA_DIST = \
gst-python.spec.in gst-python.spec README-docs