summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEdward Hervey <edward.hervey@collabora.co.uk>2009-08-04 17:13:11 +0200
committerEdward Hervey <edward.hervey@collabora.co.uk>2009-08-04 17:13:11 +0200
commitee8bf88ebf131cf7c7161356540efc20bf411e14 (patch)
tree90f8d4e13dd69f4086342bea5f5fac6ae45312a6 /Makefile.am
Initial code dropCHANGELOG_START
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 00000000..94bca7a2
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,39 @@
+DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
+
+SUBDIRS = \
+ gst-libs gst sys ext \
+ m4 common docs tests po
+
+DIST_SUBDIRS = \
+ gst gst-libs sys ext \
+ m4 common docs tests po
+
+# include before EXTRA_DIST for win32 assignment
+include $(top_srcdir)/common/win32.mak
+
+EXTRA_DIST = \
+ gst-plugins-bad.spec depcomp \
+ AUTHORS COPYING NEWS README RELEASE REQUIREMENTS \
+ ChangeLog gst-plugins-bad.doap autogen.sh \
+ $(win32)
+
+DISTCLEANFILES = _stdint.h
+
+ACLOCAL_AMFLAGS = -I m4 -I common/m4
+
+include $(top_srcdir)/common/release.mak
+include $(top_srcdir)/common/po.mak
+
+check-valgrind:
+ cd tests/check && make check-valgrind
+
+if HAVE_GST_CHECK
+check-torture:
+ cd tests/check && make torture
+else
+check-torture:
+ true
+endif
+
+include $(top_srcdir)/common/coverage/lcov.mak
+