summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@centricular.com>2020-06-28 00:00:27 +0530
committerNirbheek Chauhan <nirbheek@centricular.com>2020-06-28 00:00:27 +0530
commit16aad3395cc59118ae69fe7470d80b2f8cbc2a2d (patch)
treeda98349d872b87c1cecc63c1fb1391278eca4fc0 /setup.py
parent182fb9301b1ab15d2a775b95212bf3646ade4918 (diff)
cerbero: Define a custom user agent while downloading
Some places block urllib, and others block wget / curl. Set our own agent to workaround that, and so that people can contact us in case we're doing something they don't like while downloading things. Part-of: <https://gitlab.freedesktop.org/gstreamer/cerbero/-/merge_requests/530>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 715309de..8bb1863c 100644
--- a/setup.py
+++ b/setup.py
@@ -4,6 +4,7 @@ import shutil
from setuptools import setup, find_packages
from setuptools.command import sdist as setuptools_sdist
from cerbero.utils import shell
+from cerbero.enums import CERBERO_VERSION
from distutils.dir_util import copy_tree
import distutils.log
@@ -127,7 +128,7 @@ class extended_sdist(setuptools_sdist.sdist):
setup(
name = "cerbero",
- version = '1.17.1.1',
+ version = CERBERO_VERSION,
author = "Andoni Morales",
author_email = "amorales@fluendo.com",
description = ("Multi platform build system for Open Source projects"),