diff options
author | Andoni Morales Alastruey <ylatuya@gmail.com> | 2012-04-20 03:54:30 +0200 |
---|---|---|
committer | Andoni Morales Alastruey <ylatuya@gmail.com> | 2012-04-20 12:22:38 +0200 |
commit | 8f501ab865ed10bc54eae05053f0a101bfe8636b (patch) | |
tree | f47298a47df15d767800ebfa8d47e3944cd3d697 /setup.py | |
parent | f53558e71c35d1456af1f16b6849940ed274f81f (diff) |
setup.py: add missing files to dist tarball
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 12 |
1 files changed, 7 insertions, 5 deletions
@@ -18,7 +18,8 @@ def parse_dir(dirpath, extension=None): files = shell.check_call('git ls-files %s' % dirpath).split('\n') files.remove('') else: - files = os.listdir(dirpath) + files = shell.check_call('find %s -type f' % dirpath).split('\n') + files.remove('') if extension is None: return files return [f for f in files if f.endswith(extension)] @@ -31,16 +32,17 @@ def datafiles(prefix): for dirname, extension in [('recipes', '.recipe'), ('packages', '.package')]: for f in parse_dir(dirname, extension): files.append((os.path.join(datadir, dirname), [f])) - for f in parse_dir('data'): - dirpath = os.path.split(f.split('/', 1)[1])[0] - files.append((os.path.join(datadir, dirpath), [f])) + for dirname in ['data', 'config']: + for f in parse_dir('data'): + dirpath = os.path.split(f.split('/', 1)[1])[0] + files.append((os.path.join(datadir, dirpath), [f])) return files #Fill manifest shutil.copy('MANIFEST.in.in', 'MANIFEST.in') with open('MANIFEST.in', 'a+') as f: - for dirname in ['recipes', 'packages', 'data']: + for dirname in ['recipes', 'packages', 'data', 'config']: f.write('\n'.join(['include %s' % x for x in parse_dir(dirname)])) f.write('\n') |