summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDavid Reveman <davidr@novell.com>2004-03-31 14:55:39 +0000
committerDavid Reveman <davidr@novell.com>2004-03-31 14:55:39 +0000
commit8393b48b7d95ed417a07198fc6300d4ac0b6236d (patch)
tree79c1c27d63cda226b685cb2de00ff636523dd6c0 /configure.in
parent73cbe8f2cb69469f2477d513934c9f4051718130 (diff)
Fixed misplacement of AM_CONDITIONAL macros
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in28
1 files changed, 16 insertions, 12 deletions
diff --git a/configure.in b/configure.in
index 4365920..cfcdbe7 100644
--- a/configure.in
+++ b/configure.in
@@ -66,12 +66,6 @@ AC_ARG_ENABLE(glx,
AC_HELP_STRING([--disable-glx], [Disable glitz's GLX backend]),
[use_glx=$enableval], [use_glx=yes])
-AC_ARG_ENABLE(agl,
- AC_HELP_STRING([--disable-agl], [Disable glitz's AGL backend]),
- [use_agl=$enableval], [use_agl=yes])
-
-dnl ===========================================================================
-
AH_TEMPLATE([XTHREADS], [Define if Xlib supports XTHREADS])
if test "x$use_glx" = "xyes"; then
@@ -106,18 +100,26 @@ if test "x$use_glx" = "xyes"; then
fi
use_glx="yes"
- AM_CONDITIONAL(GLITZ_BUILD_GLX_BACKEND, true)
else
use_glx="no"
- AM_CONDITIONAL(GLITZ_BUILD_GLX_BACKEND, false)
fi
fi
+if test "x$use_glx" = "xyes"; then
+ AM_CONDITIONAL(GLITZ_BUILD_GLX_BACKEND, true)
+else
+ AM_CONDITIONAL(GLITZ_BUILD_GLX_BACKEND, false)
+fi
+
AC_SUBST(GLX_CFLAGS)
AC_SUBST(GLX_LIBS)
dnl ===========================================================================
+AC_ARG_ENABLE(agl,
+ AC_HELP_STRING([--disable-agl], [Disable glitz's AGL backend]),
+ [use_agl=$enableval], [use_agl=yes])
+
AH_TEMPLATE([PTHREADS], [Define if PTHREADS are supported])
if test "x$use_agl" = "xyes"; then
@@ -143,13 +145,15 @@ if test "x$use_agl" = "xyes"; then
AC_DEFINE(PTHREADS, 1)
fi
AC_MSG_RESULT($use_pthreads)
-
- AM_CONDITIONAL(GLITZ_BUILD_AGL_BACKEND, true)
- else
- AM_CONDITIONAL(GLITZ_BUILD_AGL_BACKEND, false)
fi
fi
+if test "x$use_agl" = "xyes"; then
+ AM_CONDITIONAL(GLITZ_BUILD_AGL_BACKEND, true)
+else
+ AM_CONDITIONAL(GLITZ_BUILD_AGL_BACKEND, false)
+fi
+
AC_SUBST(AGL_CFLAGS)
AC_SUBST(AGL_LIBS)