summaryrefslogtreecommitdiff
path: root/docs/reference/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'docs/reference/meson.build')
-rw-r--r--docs/reference/meson.build14
1 files changed, 8 insertions, 6 deletions
diff --git a/docs/reference/meson.build b/docs/reference/meson.build
index 1e8cb07..ba8a41a 100644
--- a/docs/reference/meson.build
+++ b/docs/reference/meson.build
@@ -1,8 +1,8 @@
# docs/reference
# Input: project_build_root, project_source_root, cairomm_pcname,
-# perl, build_documentation, source_h_files,
-# install_datadir, python3, doc_reference_py
+# build_documentation, source_h_files, install_datadir, python3,
+# doc_reference_py
# Output: install_docdir, install_devhelpdir, book_name
# There are no built source files in cairomm.
@@ -25,10 +25,13 @@ foreach module : tag_file_modules
htmlrefdir = htmlrefpub
endif
doxygen_tagfiles += ' "' + doxytagfile + '=' + htmlrefpub + '"'
- if not htmlrefdir.endswith('/')
- htmlrefdir += '/'
- endif
+
+ # Doxygen <= 1.8.15
docinstall_flags += ['-l', doxytagfile.split('/')[-1] + '@' + htmlrefdir]
+ if htmlrefpub != htmlrefdir
+ # Doxygen >= 1.8.16
+ docinstall_flags += ['-l', 's@' + htmlrefpub + '@' + htmlrefdir]
+ endif
endif
endforeach
@@ -45,7 +48,6 @@ doc_conf_data.set('abs_top_builddir', project_build_root)
doc_conf_data.set('abs_top_srcdir', project_source_root)
doc_conf_data.set('CAIROMM_MODULE_NAME', book_name)
doc_conf_data.set('DOXYGEN_TAGFILES', doxygen_tagfiles)
-doc_conf_data.set('PERL', perl.found() ? perl.path() : '')
configure_file(
input: 'Doxyfile.in',