summaryrefslogtreecommitdiff
path: root/docs/reference/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'docs/reference/meson.build')
-rw-r--r--docs/reference/meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/docs/reference/meson.build b/docs/reference/meson.build
index ba8a41a..91bf6e2 100644
--- a/docs/reference/meson.build
+++ b/docs/reference/meson.build
@@ -3,7 +3,7 @@
# Input: project_build_root, project_source_root, cairomm_pcname,
# build_documentation, source_h_files, install_datadir, python3,
# doc_reference_py
-# Output: install_docdir, install_devhelpdir, book_name
+# Output: install_docdir, install_devhelpdir, book_name, tag_file
# There are no built source files in cairomm.
@@ -16,9 +16,9 @@ docinstall_flags = []
foreach module : tag_file_modules
depmod = dependency(module, required: false)
if depmod.found()
- doxytagfile = depmod.get_pkgconfig_variable('doxytagfile')
- htmlrefpub = depmod.get_pkgconfig_variable('htmlrefpub', default: '')
- htmlrefdir = depmod.get_pkgconfig_variable('htmlrefdir', default: '')
+ doxytagfile = depmod.get_variable(pkgconfig: 'doxytagfile', internal: 'doxytagfile')
+ htmlrefpub = depmod.get_variable(pkgconfig: 'htmlrefpub', internal: 'htmlrefpub', default_value: '')
+ htmlrefdir = depmod.get_variable(pkgconfig: 'htmlrefdir', internal: 'htmlrefdir', default_value: '')
if htmlrefpub == ''
htmlrefpub = htmlrefdir
elif htmlrefdir == ''