summaryrefslogtreecommitdiff
path: root/docs/reference/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'docs/reference/Makefile.am')
-rw-r--r--docs/reference/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/docs/reference/Makefile.am b/docs/reference/Makefile.am
index 934740a..416df77 100644
--- a/docs/reference/Makefile.am
+++ b/docs/reference/Makefile.am
@@ -2,14 +2,15 @@ DOXYGEN_CONFIGFILE = Doxyfile
DOXYGEN_CONFIGFILE_SOURCE = Doxyfile.in
WEB_SERVER = cairographics.org
WEB_SERVER_PATH = /srv/cairo.freedesktop.org/www/documentation/cairomm/reference
+HTML_TEMPLATE_FILES = cairomm.css cairomm-header.html
EXTRA_DIST = $(DOXYGEN_CONFIGFILE_SOURCE) \
- introduction.h cairomm_doxygen_tags \
+ introduction.h $(HTML_TEMPLATE_FILES) cairomm_doxygen_tags \
html
index_html = html/index.html
-$(index_html): $(DOXYGEN_CONFIGFILE) $(wildcard $(top_srcdir)/cairomm/*.h)
+$(index_html): $(DOXYGEN_CONFIGFILE) $(wildcard $(top_srcdir)/cairomm/*.h) $(HTML_TEMPLATE_FILES)
-rm -rf html
doxygen $(DOXYGEN_CONFIGFILE) \
2> doxygen-warnings.txt | tee doxygen-output.txt && cat doxygen-warnings.txt