summaryrefslogtreecommitdiff
path: root/docs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'docs/Makefile.am')
-rw-r--r--docs/Makefile.am24
1 files changed, 21 insertions, 3 deletions
diff --git a/docs/Makefile.am b/docs/Makefile.am
index 9b51ce1..5fd62bf 100644
--- a/docs/Makefile.am
+++ b/docs/Makefile.am
@@ -1,10 +1,28 @@
+## Copyright (c) 2009 Openismus GmbH <http://www.openismus.com/>
+##
+## This file is part of cairomm.
+##
+## cairomm is free software: you can redistribute it and/or modify it
+## under the terms of the GNU Lesser General Public License as published
+## by the Free Software Foundation, either version 2.1 of the License,
+## or (at your option) any later version.
+##
+## cairomm is distributed in the hope that it will be useful, but
+## WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
+## See the GNU Lesser General Public License for more details.
+##
+## You should have received a copy of the GNU Lesser General Public License
+## along with this library. If not, see <http://www.gnu.org/licenses/>.
+
include $(top_srcdir)/cairomm/filelist.am
book_name = $(CAIROMM_MODULE_NAME)
-doc_input = $(addprefix $(top_srcdir)/cairomm/,$(files_extra_h))
+doc_input = $(addprefix $(top_srcdir)/cairomm/,$(cairomm_public_h))
-htmlrefpub = http://www.cairographics.org/documentation/$(book_name)/reference/
+pubdocbase = http://www.cairographics.org/documentation/
+htmlrefpub = $(pubdocbase)cairomm/reference
include $(top_srcdir)/build/doc-reference.am
-dist_noinst_DATA += reference/cairomm-header.html
+dist_noinst_DATA += reference/cairomm.css reference/cairomm-header.html