summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index f0d935d..9c0d2c6 100644
--- a/configure.in
+++ b/configure.in
@@ -120,7 +120,10 @@ else
fi
AM_CONDITIONAL(AUTOTESTS, test x$ENABLE_TESTS = xyes)
-
+dnl enable compiler warnings when the CAIROMM_DEVEL environment variable is set to 'on'
+if test "x$CAIROMM_DEVEL" = "xon" ; then
+ CXXFLAGS="$CXXFLAGS -Wall -g -Werror -Wextra"
+fi
dnl Check whether to build the documentation directory