summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2021-11-10 16:11:04 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2021-11-10 16:37:35 +0800
commit7a77ad0d31f5024c2aed6bdc3c98b790836e9290 (patch)
tree8a86a115156ecf7131db3aca8dbe3a9fe49af0c2 /meson.build
parentec5f5d5e940e2e798f7df3c50d55129a797e1d41 (diff)
build: Support Visual Studio 2022
Make these builds distinct from the Visual Studio 2019 builds.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index a8435da..3a4f63a 100644
--- a/meson.build
+++ b/meson.build
@@ -231,7 +231,9 @@ if is_msvc
add_project_arguments(disabled_warning, language: 'cpp')
endforeach
if use_msvc14x_toolset_ver
- if cpp_compiler.version().version_compare('>=19.20')
+ if cpp_compiler.version().version_compare('>=19.30')
+ msvc14x_toolset_ver = '-vc143'
+ elif cpp_compiler.version().version_compare('>=19.20')
msvc14x_toolset_ver = '-vc142'
elif cpp_compiler.version().version_compare('>=19.10')
msvc14x_toolset_ver = '-vc141'