summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorKjell Ahlstedt <kjellahlstedt@gmail.com>2020-09-30 09:26:12 +0200
committerKjell Ahlstedt <kjellahlstedt@gmail.com>2020-09-30 09:26:12 +0200
commit4ccc0a5315d09a8ae6ddba53f855c0bca56971a1 (patch)
treef87b42da64f0697684b802996ff00dd0564044c0 /meson.build
parent9db4b39bfe50e183130b89824a3556da09cd51cb (diff)
Add tools/doc-publish.sh and release-publish.sh
Scripts that simplify releasing new versions of cairomm.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 7 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 6c3a6bf..5b25206 100644
--- a/meson.build
+++ b/meson.build
@@ -1,7 +1,7 @@
# This file is part of cairomm.
project('cairomm', 'cpp',
- version: '1.16.0',
+ version: '1.16.1',
license: 'LGPLv2+',
default_options: [
'cpp_std=c++17',
@@ -270,12 +270,18 @@ if not meson.is_subproject()
python3.path(), dist_changelog_py,
project_source_root,
)
+ # Don't distribute these files and directories.
+ dont_distribute = [
+ 'tools',
+ ]
+
# Add build scripts to the distribution directory, and delete .gitignore
# files and an empty $MESON_DIST_ROOT/build/ directory.
meson.add_dist_script(
python3.path(), dist_build_scripts_py,
project_source_root,
'untracked' / 'build_scripts',
+ dont_distribute,
)
endif