summaryrefslogtreecommitdiff
path: root/docs/reference/Makefile.am
diff options
context:
space:
mode:
authorJonathon Jongsma <jjongsma@gnome.org>2006-05-09 03:12:42 +0000
committerJonathon Jongsma <jjongsma@gnome.org>2006-05-09 03:12:42 +0000
commit5eed66307338f5ee7ae63c02986f49e5e10819af (patch)
tree599d1335cb1d90f94de3c8be2f3927e88f9a9052 /docs/reference/Makefile.am
parent2e6b32ec83cfbabee8b453ab7bc52aaac73bd3fc (diff)
2006-05-08 Jonathon Jongsma <jonathon.jongsma@gmail.com>
* cairomm/cairomm.h: Add doxygen API introduction test here. * docs/reference/Doxyfile.in: * docs/reference/Makefile.am: * docs/reference/cairomm-header.html: * docs/reference/cairomm.css: * docs/reference/introduction.h: fix up some documentation presentation issues that turned up with newer versions of doxygen.
Diffstat (limited to 'docs/reference/Makefile.am')
-rw-r--r--docs/reference/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/docs/reference/Makefile.am b/docs/reference/Makefile.am
index 934740a..416df77 100644
--- a/docs/reference/Makefile.am
+++ b/docs/reference/Makefile.am
@@ -2,14 +2,15 @@ DOXYGEN_CONFIGFILE = Doxyfile
DOXYGEN_CONFIGFILE_SOURCE = Doxyfile.in
WEB_SERVER = cairographics.org
WEB_SERVER_PATH = /srv/cairo.freedesktop.org/www/documentation/cairomm/reference
+HTML_TEMPLATE_FILES = cairomm.css cairomm-header.html
EXTRA_DIST = $(DOXYGEN_CONFIGFILE_SOURCE) \
- introduction.h cairomm_doxygen_tags \
+ introduction.h $(HTML_TEMPLATE_FILES) cairomm_doxygen_tags \
html
index_html = html/index.html
-$(index_html): $(DOXYGEN_CONFIGFILE) $(wildcard $(top_srcdir)/cairomm/*.h)
+$(index_html): $(DOXYGEN_CONFIGFILE) $(wildcard $(top_srcdir)/cairomm/*.h) $(HTML_TEMPLATE_FILES)
-rm -rf html
doxygen $(DOXYGEN_CONFIGFILE) \
2> doxygen-warnings.txt | tee doxygen-output.txt && cat doxygen-warnings.txt