summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJonathon Jongsma <jjongsma@gnome.org>2007-03-24 03:05:33 +0000
committerJonathon Jongsma <jjongsma@gnome.org>2007-03-24 03:05:33 +0000
commit2d59e18935e5ea28814cc522c431c0caabe3cd84 (patch)
tree0e203313c1fb867c10c5b70bac5f793d5b2ce517 /configure.in
parentea07f5b2076a75ac15e9b3f99c4f8285a857c0d1 (diff)
2007-03-23 Jonathon Jongsma <jjongsma@gnome.org>
* Makefile.am: * autogen.sh: * configure.in: * m4/ax_boost_base.m4: * m4/ax_boost_unit_test_framework.m4: Add some basic test infrastructure. It's disabled by default, and must be explicitly enabled by passing --enable-tests to configure (or by setting the CAIROMM_DEVEL environment variable to "on"). It uses the boost unit test framework, but this should not be required unless you've explicitly enabled tests. If tests are enabled, you can easily run them with 'make check' * tests/Makefile.am: * tests/test-context.cc: added the beginning of a test for Cairo::Context. Most of these tests are really very interesting. Basically what I'm trying to do is a) test some basic behaviors, and b) excercise the functionality a little bit. One of the tests currently fails due to a RefPtr::cast_dynamic failure, so I have to see what's going on there.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in23
1 files changed, 22 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 2a55412..f0d935d 100644
--- a/configure.in
+++ b/configure.in
@@ -28,7 +28,6 @@ AC_SUBST(GENERIC_LIBRARY_VERSION)
VERSION=$GENERIC_VERSION
-
AM_INIT_AUTOMAKE(cairomm, $GENERIC_VERSION)
AC_PROG_CXX
@@ -103,6 +102,26 @@ AC_CHECK_HEADERS(string list map, , exit)
PKG_CHECK_MODULES(CAIROMM, cairo >= 1.3.10)
+AC_ARG_ENABLE(tests,
+ AC_HELP_STRING([--enable-tests=yes|no],
+ [enable automated tests (default is no)]),
+ ENABLE_TESTS=$enableval,
+ ENABLE_TESTS=no)
+if test x$CAIROMM_DEVEL = xon ; then
+ ENABLE_TESTS=yes
+fi
+
+if test x$ENABLE_TESTS = xyes ; then
+AX_BOOST_BASE([1.33.1])
+AX_BOOST_UNIT_TEST_FRAMEWORK
+AC_MSG_NOTICE(support of automated tests enabled)
+else
+ AC_MSG_NOTICE(disabled support of automated tests)
+fi
+AM_CONDITIONAL(AUTOTESTS, test x$ENABLE_TESTS = xyes)
+
+
+
dnl Check whether to build the documentation directory
DOCS_SUBDIR="" dnl set DOCS_SUBDIR initially blank
@@ -143,6 +162,8 @@ AC_CONFIG_FILES(
examples/svg-surface/Makefile
examples/text-rotate/Makefile
+ tests/Makefile
+
cairomm-1.0.pc
)