summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJonathon Jongsma <jjongsma@gnome.org>2006-02-08 00:55:17 +0000
committerJonathon Jongsma <jjongsma@gnome.org>2006-02-08 00:55:17 +0000
commit1b1cc575b66902fef7887ef3539ec3afc83011ff (patch)
tree74b201c4d49b2cf471fcf8b5908ffb3320c85cb2 /configure.in
parentbbfb66f4568f68e1c62e6302e699619f9debac7f (diff)
2006-02-07 Jonathon Jongsma <jonathon.jongsma@gmail.com>
* Makefile.am: add docs/ subdir * configure.in: added an --enable-docs switch to the configure script (enabled by default), and added AC_OUTPUT directives for the documentation Makefiles, etc. * docs/.cvsignore: * docs/Makefile.am: * docs/reference/.cvsignore: * docs/reference/Doxyfile.in: * docs/reference/Makefile.am: * docs/reference/introduction.h: Added infrastructure to build and install the API documentation for cairomm (based on libxml++ makefiles).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 3ded40e..f32856b 100644
--- a/configure.in
+++ b/configure.in
@@ -94,10 +94,26 @@ PKG_CHECK_MODULES(CAIROMM, cairo >= 1.0)
GLIBMM_CHECK_PERL([5.6.0])
+
+AC_ARG_ENABLE(docs, [AC_HELP_STRING([--enable-docs],
+ [build the included docs [default=yes]])],,
+ [enable_docs=yes])
+if test "x$enable_docs" = "xyes"; then
+ DOCS_SUBDIR="docs"
+else
+ DOCS_SUBDIR=""
+fi
+AC_SUBST(DOCS_SUBDIR)
+
+
AC_OUTPUT(
Makefile
cairomm/Makefile
+ docs/Makefile
+ docs/reference/Makefile
+ docs/reference/Doxyfile
+
examples/Makefile
examples/png_file/Makefile
examples/pdf-surface/Makefile