summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid King <davidk@openismus.com>2009-08-12 15:06:22 +0200
committerJonathon Jongsma <jjongsma@gnome.org>2009-08-13 11:08:52 -0500
commitd4000533781d05a550d3be40ca67d4429a01acec (patch)
tree4c9415db1b6734e04e6f811606818ebc20faa783 /configure.ac
parentde4e75a5e588ab8689bfe405391ff3c788c94018 (diff)
Get rid of all Makefile.am in the MSVC dirs
* MSVC_Net2005/**/.cvsignore: * MSVC_Net2008/**/.cvsignore: Remove obsolete .cvsignore files. * MSVC_Net2005/**/Makefile.am: * MSVC_Net2008/**/Makefile.am: Remove recursive build files. * MSVC_Net2005/filelist.am: * MSVC_Net2008/filelist.am: Recursively list all files that should go into the distribution. * configure.ac (AC_CONFIG_FILES): Remove all Makefile outputs to the MSVC subdirectories. (AC_CONFIG_COMMANDS): Copy the configuration header files into the MSVC subdirectories by making config.status execute custom configuration commands. This is easier than doing it at the Makefile level, where it was previously implemented. * Makefile.am: Include the filelist.am files from the MSVC subdirectories. (SUBDIRS): Remove MSVC_Net200[58] directories from the list. (dist_noinst_DATA): Distribute the MSVC project files. (DISTCLEANFILES): Include the copied configuration header files in a distclean.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 7 insertions, 25 deletions
diff --git a/configure.ac b/configure.ac
index 18dcdde..8df9f06 100644
--- a/configure.ac
+++ b/configure.ac
@@ -212,30 +212,12 @@ CAIROMM_ARG_ENABLE_API_EXCEPTIONS
AC_CONFIG_FILES([
$CONFIG_PC
- MSVC_Net2005/Makefile
- MSVC_Net2005/gendef/Makefile
- MSVC_Net2005/cairomm/Makefile
- MSVC_Net2005/cairomm/cairomm.rc
- MSVC_Net2005/examples/Makefile
- MSVC_Net2005/examples/pdf-surface/Makefile
- MSVC_Net2005/examples/ps-surface/Makefile
- MSVC_Net2005/examples/svg-surface/Makefile
- MSVC_Net2005/examples/image-surface/Makefile
- MSVC_Net2005/examples/text-rotate/Makefile
- MSVC_Net2005/examples/toy-text/Makefile
- MSVC_Net2005/examples/user-font/Makefile
- MSVC_Net2008/Makefile
- MSVC_Net2008/gendef/Makefile
- MSVC_Net2008/cairomm/Makefile
- MSVC_Net2008/cairomm/cairomm.rc
- MSVC_Net2008/examples/Makefile
- MSVC_Net2008/examples/pdf-surface/Makefile
- MSVC_Net2008/examples/ps-surface/Makefile
- MSVC_Net2008/examples/svg-surface/Makefile
- MSVC_Net2008/examples/image-surface/Makefile
- MSVC_Net2008/examples/text-rotate/Makefile
- MSVC_Net2008/examples/toy-text/Makefile
- MSVC_Net2008/examples/user-font/Makefile
-])
+ MSVC_Net2005/cairomm/cairomm.rc
+ MSVC_Net2008/cairomm/cairomm.rc])
+
+AC_CONFIG_COMMANDS([MSVC_Net2005/cairomm/cairommconfig.h],
+ [cp -f cairomm/cairommconfig.h MSVC_Net2005/cairomm/cairommconfig.h])
+AC_CONFIG_COMMANDS([MSVC_Net2008/cairomm/cairommconfig.h],
+ [cp -f cairomm/cairommconfig.h MSVC_Net2008/cairomm/cairommconfig.h])
AC_OUTPUT