summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJonathon Jongsma <jjongsma@gnome.org>2007-03-24 03:05:33 +0000
committerJonathon Jongsma <jjongsma@gnome.org>2007-03-24 03:05:33 +0000
commit2d59e18935e5ea28814cc522c431c0caabe3cd84 (patch)
tree0e203313c1fb867c10c5b70bac5f793d5b2ce517 /Makefile.am
parentea07f5b2076a75ac15e9b3f99c4f8285a857c0d1 (diff)
2007-03-23 Jonathon Jongsma <jjongsma@gnome.org>
* Makefile.am: * autogen.sh: * configure.in: * m4/ax_boost_base.m4: * m4/ax_boost_unit_test_framework.m4: Add some basic test infrastructure. It's disabled by default, and must be explicitly enabled by passing --enable-tests to configure (or by setting the CAIROMM_DEVEL environment variable to "on"). It uses the boost unit test framework, but this should not be required unless you've explicitly enabled tests. If tests are enabled, you can easily run them with 'make check' * tests/Makefile.am: * tests/test-context.cc: added the beginning of a test for Cairo::Context. Most of these tests are really very interesting. Basically what I'm trying to do is a) test some basic behaviors, and b) excercise the functionality a little bit. One of the tests currently fails due to a RefPtr::cast_dynamic failure, so I have to see what's going on there.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 9387b03..3fc2fd5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,8 @@
## Process this file with automake to produce Makefile.in
-SUBDIRS = cairomm examples MSVC $(DOCS_SUBDIR)
+SUBDIRS = cairomm examples MSVC $(DOCS_SUBDIR) tests
#docs examples
+ACLOCAL_AMFLAGS = -I m4
EXTRA_DIST = MAINTAINERS cairomm-1.0.pc.in