summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid King <davidk@openismus.com>2009-08-12 15:06:22 +0200
committerJonathon Jongsma <jjongsma@gnome.org>2009-08-13 11:08:52 -0500
commitd4000533781d05a550d3be40ca67d4429a01acec (patch)
tree4c9415db1b6734e04e6f811606818ebc20faa783 /Makefile.am
parentde4e75a5e588ab8689bfe405391ff3c788c94018 (diff)
Get rid of all Makefile.am in the MSVC dirs
* MSVC_Net2005/**/.cvsignore: * MSVC_Net2008/**/.cvsignore: Remove obsolete .cvsignore files. * MSVC_Net2005/**/Makefile.am: * MSVC_Net2008/**/Makefile.am: Remove recursive build files. * MSVC_Net2005/filelist.am: * MSVC_Net2008/filelist.am: Recursively list all files that should go into the distribution. * configure.ac (AC_CONFIG_FILES): Remove all Makefile outputs to the MSVC subdirectories. (AC_CONFIG_COMMANDS): Copy the configuration header files into the MSVC subdirectories by making config.status execute custom configuration commands. This is easier than doing it at the Makefile level, where it was previously implemented. * Makefile.am: Include the filelist.am files from the MSVC subdirectories. (SUBDIRS): Remove MSVC_Net200[58] directories from the list. (dist_noinst_DATA): Distribute the MSVC project files. (DISTCLEANFILES): Include the copied configuration header files in a distclean.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 51fb380..161c9a6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,7 +3,7 @@ doc_subdirs = docs
else
doc_subdirs =
endif
-SUBDIRS = cairomm $(doc_subdirs) data examples MSVC_Net2005 MSVC_Net2008 tests
+SUBDIRS = cairomm $(doc_subdirs) data examples tests
ACLOCAL_AMFLAGS = -I build ${ACLOCAL_FLAGS}
DISTCHECK_CONFIGURE_FLAGS = --enable-warnings=fatal
@@ -15,6 +15,16 @@ nodist_cairomm_libinclude_HEADERS = cairomm/cairommconfig.h
pkgconfigdir = $(libdir)/pkgconfig
nodist_pkgconfig_DATA = data/$(CAIROMM_MODULE_NAME).pc
+include $(srcdir)/MSVC_Net2005/filelist.am
+include $(srcdir)/MSVC_Net2008/filelist.am
+
+msvc_files = $(msvc_net2005_data:%=MSVC_Net2005/%) $(msvc_net2008_data:%=MSVC_Net2008/%)
+
+dist_noinst_DATA = $(msvc_files)
+
+DISTCLEANFILES = MSVC_Net2005/cairomm/cairommconfig.h \
+ MSVC_Net2008/cairomm/cairommconfig.h
+
dist_noinst_SCRIPTS = autogen.sh
###