summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMathias Hasselmann <mathias.hasselmann@gmx.de>2007-03-16 20:43:29 +0100
committerMathias Hasselmann <mathias.hasselmann@gmx.de>2007-03-16 20:43:29 +0100
commitdd4601b0d03bba021b11dcf96e09584f40d1621f (patch)
treecd82c40d8586cf6a9096183920f24a73db5a0ad2 /configure.in
parentd02aa5b23eb6243b21697de203db0a5f1b49def9 (diff)
[cairo-perf] Emit warning, if cairo-perf is not CPU bound
cairo-perf and the X server should be bound to CPUs (either the same or separate) on SMP systems. Not doing so causes random results when the X server is moved to or from cairo-perf's CPU during the benchmarks.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index d65c17eaa..75eef279b 100644
--- a/configure.in
+++ b/configure.in
@@ -577,6 +577,17 @@ dnl Checks for precise integer types
AC_CHECK_HEADERS([stdint.h signal.h inttypes.h sys/int_types.h])
AC_CHECK_TYPES([uint64_t, uint128_t])
+dnl ===========================================================================
+dnl check for CPU affinity support
+AC_CHECK_HEADERS([sched.h], [
+ AC_CHECK_FUNCS([sched_getaffinity], [
+ AC_DEFINE([HAVE_SCHED_GETAFFINITY], [1],
+ [Define to 1 if you have Linux compatible sched_getaffinity])
+ ])
+])
+
+dnl ===========================================================================
+dnl check compiler flags
AC_DEFUN([CAIRO_CC_TRY_FLAG], [
AC_MSG_CHECKING([whether $CC supports $1])