summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHans de Goede <hdegoede@redhat.com>2012-01-11 17:06:15 +0100
committerHans de Goede <hdegoede@redhat.com>2012-01-15 20:43:53 +0100
commitcc6aace26ce9f8dcfc6e406335c82c05a73e7d5a (patch)
tree6a99a9a7a6d87549f839b792af416dcc9d7f1da2 /configure.ac
parentd8246e2b7c0a5c6fd1558922b8568f0b6744b883 (diff)
usbredir: Add support for filtering out devices from auto-redirection
Note this patch adds a default filter filtering out HID devices, since redirecting ie a mouse plugged into a laptop is usually not what the user wants. Also sometimes usb keyboards/mice may experience a glitch causing them to temporarily drop of the bus. If this happens when the spice-client has focussed it used to redirect them to the vm when they re-appeared, not good! Signed-off-by: Hans de Goede <hdegoede@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 71f24ae..2dd9e9d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -330,7 +330,7 @@ if test "x$enable_usbredir" = "xno"; then
else
PKG_CHECK_MODULES(GUDEV, gudev-1.0)
PKG_CHECK_MODULES(LIBUSB, libusb-1.0 >= 1.0.9)
- PKG_CHECK_MODULES(LIBUSBREDIRHOST, libusbredirhost >= 0.3.2)
+ PKG_CHECK_MODULES(LIBUSBREDIRHOST, libusbredirhost >= 0.3.3)
AC_DEFINE(USE_USBREDIR, [1], [Define if supporting usbredir proxying])
AM_CONDITIONAL(WITH_USBREDIR, true)
if test "x$enable_polkit" = "xno"; then