summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@redhat.com>2012-02-21 12:09:19 +0100
committerMarc-André Lureau <marcandre.lureau@redhat.com>2012-02-22 15:57:35 +0100
commita41f9bcd53a2db9c7144b1e8613b287b1117abdc (patch)
tree1fdb8ffd692b58eebcb53703b907a0ea386cec1a /configure.ac
parente206e1a6e1d93e53752d5258815c23bd805a96d9 (diff)
RFC: Use spice protocol as a submodule
Spice protocol contains only headers. We would like to be able to use a protocol update without having to wait for the release, a git submodule works well for this purpose.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 7 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 7876378..7332b6d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,14 +59,16 @@ AM_CONDITIONAL([OS_WIN32],[test "$os_win32" = "yes"])
AC_CHECK_HEADERS([sys/ipc.h sys/shm.h])
AC_CHECK_HEADERS([sys/socket.h netinet/in.h arpa/inet.h])
-dnl =========================================================================
-dnl Chek optional features
-PKG_CHECK_MODULES(PROTOCOL, spice-protocol >= 0.10.2)
-AC_SUBST(PROTOCOL_CFLAGS)
-
AC_CHECK_LIBM
AC_SUBST(LIBM)
+AC_CONFIG_SUBDIRS([spice-protocol])
+PROTOCOL_CFLAGS='-I ${top_srcdir}/spice-protocol'
+AC_SUBST(PROTOCOL_CFLAGS)
+
+dnl =========================================================================
+dnl Chek optional features
+
srcdir="$(dirname $0)"
if test ! -e "$srcdir/gtk/generated_marshallers.c"; then
AC_MSG_CHECKING([for pyparsing python module])