summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2011-05-19 15:59:07 +0200
committerChristophe Fergeau <cfergeau@redhat.com>2012-01-24 18:39:48 +0100
commit9e21078064d3ddc5faf9f3b91663215ab8b693c2 (patch)
tree4926346fde79415db72c66f683eea719db7bdfe9 /configure.ac
parent8e3b1d144a8eba5995a450136286ac5750489622 (diff)
Add check for Perl::Text::CSV
This check is only added to configure.ac contrary to the pyparsing patch.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3df1298..2cb4075 100644
--- a/configure.ac
+++ b/configure.ac
@@ -78,6 +78,16 @@ if test ! -e "$srcdir/gtk/generated_marshallers.c"; then
AC_MSG_RESULT([found])
fi
+if test ! -e "$srcdir/gtk/vncdisplaykeymap_osx2xtkbd.c"; then
+ AC_MSG_CHECKING([for Text::CSV Perl module])
+ perl -MText::CSV -e "" >/dev/null 2>&1
+ if test $? -ne 0 ; then
+ AC_MSG_RESULT([not found])
+ AC_MSG_ERROR([Text::CSV Perl module is required to compile this package])
+ fi
+ AC_MSG_RESULT([found])
+fi
+
SPICE_GLIB_REQUIRES=""
SPICE_GTK_REQUIRES=""