summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@redhat.com>2010-12-05 22:16:35 +0100
committerMarc-André Lureau <marcandre.lureau@redhat.com>2010-12-05 22:19:16 +0100
commit165000de77f0e334181a4cf1f613a0a1d4898f3d (patch)
tree597ec7110dc48f049b6394f1b8ecab794b5578d5 /Makefile.am
parent37d88ef2d31dfb894f0f0349137284b381fe5cd3 (diff)
gtk: first stab at gtk-doc documentation
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am28
1 files changed, 26 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 9baaff2..e922c42 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,7 @@
ACLOCAL_AMFLAGS = -I m4
+NULL =
-SUBDIRS = common gtk po python_modules
+SUBDIRS = common gtk po python_modules doc
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = spice-client-glib.pc spice-client-gtk.pc
@@ -13,15 +14,35 @@ DISTCLEANFILES = $(pkgconfig_DATA) \
intltool-extract \
intltool-merge \
intltool-update \
+ gnome-doc-utils.make \
+ gtk-doc.make \
po/.intltool-merge-cache
EXTRA_DIST = spice.proto \
spice1.proto \
spice_codegen.py \
build-aux/git-version-gen \
+ gtk-doc.make \
.version \
$(INTLTOOL_FILES)
+MAINTAINERCLEANFILES = \
+ ABOUT-NLS \
+ aclocal.m4 \
+ config.h.in \
+ m4/*.m4 \
+ build-aux/compile \
+ build-aux/config.guess \
+ build-aux/config.rpath \
+ build-aux/config.sub \
+ build-aux/depcomp \
+ build-aux/install-sh \
+ build-aux/ltmain.sh \
+ build-aux/missing \
+ build-aux/mkinstalldirs \
+ po/Makefile.in.in \
+ $(NULL)
+
# see git-version-gen
dist-hook:
echo $(VERSION) > $(distdir)/.tarball-version
@@ -30,4 +51,7 @@ BUILT_SOURCES = $(top_srcdir)/.version
$(top_srcdir)/.version:
echo $(VERSION) > $@-t && mv $@-t $@
-DISTCHECK_CONFIGURE_FLAGS = --enable-introspection --enable-werror
+DISTCHECK_CONFIGURE_FLAGS = --enable-introspection --enable-werror --enable-gtk-doc
+
+-include $(top_srcdir)/git.mk
+