summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPlamena Manolova <plamena.n.manolova@intel.com>2013-02-22 14:56:05 +0000
committerLionel Landwerlin <llandwerlin@gmail.com>2013-06-21 18:57:24 +0100
commit1eca1631a74f866095b0fc85f2b8b20d82ce2894 (patch)
treeb29e2c4ddeb0da45a9deb914a72047a8fa50f5e4 /Makefile.am
parent29b01c2aba99ed828f43a614b30b49c52a28557f (diff)
Include CoglGst
CoglGst is a GStreamer integration library that facilitates video playback using the Cogl API. It works by retrieving each video frame from the GStreamer pipeline and attaching it to a Cogl pipeline in the form of a Cogl texture along with possible color model conversion shaders. The pipeline is then retrieved by the user during each draw. An example use of the CoglGst API is included in the examples directory. Reviewed-by: Neil Roberts <neil@linux.intel.com> (cherry picked from commit dfb94cf4b0b6b42d6465df362a0c0af780596890)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 7a1eb7bb..308e66c2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,6 +8,10 @@ if BUILD_COGL_GLES2
SUBDIRS += cogl-gles2
endif
+if BUILD_COGL_GST
+SUBDIRS += cogl-gst
+endif
+
SUBDIRS += examples doc po build
ACLOCAL_AMFLAGS = -I build/autotools ${ACLOCAL_FLAGS}
@@ -32,6 +36,7 @@ DISTCHECK_CONFIGURE_FLAGS = \
--enable-xlib-egl-platform \
--enable-wayland-egl-platform \
--enable-glx \
- --enable-wayland-egl-server
+ --enable-wayland-egl-server \
+ --enable-cogl-gst
include $(top_srcdir)/build/autotools/Makefile.am.release