summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTim Lauridsen <tla@rasmil.dk>2007-09-25 09:32:29 +0200
committerTim Lauridsen <tla@rasmil.dk>2007-09-25 09:32:55 +0200
commit3ec379272d04305afe45ffa3bbd3c98ceed79437 (patch)
treebe7bdcf74c19a7e20aaa559aebea718c742cf028 /Makefile.am
parent9310d28d723cbdae1c5ef31e78014b0d0a581dff (diff)
* Moved python/__init__.py python/packagekit/__init__.py
* Moved backends/yum/helpers/packagekit.py -> python/packagekit/backend.py So that the PackageKitBaseBackend python class used byt yum & conary is part of the packagekit python module and be used by 'from packagekit.backend import PackageKitBaseBackend' added links from python/packagekit to yum/helpers & conary/helpers so that the python code will work when started in the directory. make changes to the Makefile's to support the changes.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 5063b360..43fb928a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,7 +23,11 @@ dbusdir = ${SYSCONFDIR}/dbus-1/system.d
dist_dbus_DATA = PackageKit.conf
packagekitpythondir = ${PYTHON_PACKAGE_DIR}
-packagekitpython_PYTHON = python/__init__.py
+packagekitpython_PYTHON = \
+ python/packagekit/__init__.py \
+ python/packagekit/backend.py \
+ $(NULL)
+
EXTRA_DIST = \
PackageKit.conf.in \