summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorArmin Krezović <krezovic.armin@gmail.com>2016-12-09 22:58:27 +0100
committerDaniel Stone <daniels@collabora.com>2017-01-17 12:54:03 +0000
commitb08e1a5c12d9687995a81e9ee074563ded8f2997 (patch)
treeb1238f24fd9a2ae3edd17c51b772326bc72caefb /configure.ac
parent3b7c207d06bbf24827021d3da77f9baa764974f4 (diff)
compositor-wayland: Support building without EGL
Signed-off-by: Armin Krezović <krezovic.armin@gmail.com> Reviewed-by: Daniel Stone <daniels@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 363733d0..20117592 100644
--- a/configure.ac
+++ b/configure.ac
@@ -222,11 +222,14 @@ AC_SUBST(WAYLAND_PROTOCOLS_DATADIR, $ac_wayland_protocols_pkgdatadir)
AC_ARG_ENABLE(wayland-compositor, [ --enable-wayland-compositor],,
enable_wayland_compositor=yes)
AM_CONDITIONAL(ENABLE_WAYLAND_COMPOSITOR,
- test x$enable_wayland_compositor = xyes -a x$enable_egl = xyes)
-if test x$enable_wayland_compositor = xyes -a x$enable_egl = xyes; then
+ test x$enable_wayland_compositor = xyes)
+if test x$enable_wayland_compositor = xyes; then
AC_DEFINE([BUILD_WAYLAND_COMPOSITOR], [1],
[Build the Wayland (nested) compositor])
- PKG_CHECK_MODULES(WAYLAND_COMPOSITOR, [wayland-client >= $WAYLAND_PREREQ_VERSION wayland-egl wayland-cursor])
+ PKG_CHECK_MODULES(WAYLAND_COMPOSITOR, [wayland-client >= $WAYLAND_PREREQ_VERSION wayland-cursor])
+ if test x$enable_egl = xyes; then
+ PKG_CHECK_MODULES(WAYLAND_COMPOSITOR_EGL, [wayland-egl])
+ fi
fi