summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBrian M. Clapper <bmc@clapper.org>2016-07-11 18:30:05 -0400
committerKeith Packard <keithp@keithp.com>2016-07-19 11:08:21 -0700
commit711c36558f50943c8342f25ad210281134887a3d (patch)
tree32332c26febbedf83ae452b0158c9b4662dc500a /configure.ac
parent2a79be9e4dd1b6ba00b69ff40bc5257ec84d34da (diff)
os: Add poll emulation for mingw [v2]
v2: rename as 'xserver_poll' to avoid potential library name collisions. Provide 'xserver_poll.h' which uses the system poll where available and falls back to this emulation otherwise. Autodetects when this is required, building the emulation only then Source: https://github.com/bmc/poll Signed-off-by: Adam Jackson <ajax@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 52466d11d..58fcf79d5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -219,9 +219,10 @@ dnl Checks for library functions.
AC_CHECK_FUNCS([backtrace ffs geteuid getuid issetugid getresuid \
getdtablesize getifaddrs getpeereid getpeerucred getprogname getzoneid \
mmap posix_fallocate seteuid shmctl64 strncasecmp vasprintf vsnprintf \
- walkcontext setitimer])
+ walkcontext setitimer poll])
AC_CONFIG_LIBOBJ_DIR([os])
AC_REPLACE_FUNCS([reallocarray strcasecmp strcasestr strlcat strlcpy strndup])
+AM_CONDITIONAL(POLL, [test "x$ac_cv_func_poll" = "xyes"])
AC_CHECK_DECLS([program_invocation_short_name], [], [], [[#include <errno.h>]])