summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKeith Packard <keithp@keithp.com>2009-10-21 16:46:55 +0900
committerKeith Packard <keithp@keithp.com>2009-10-21 16:46:55 +0900
commit08e7f62faf72540cb3a6f1023024c145f7fa1a23 (patch)
tree3fd52c5968cd616ed4f7cfd2bc10ee9badafd5e7 /Makefile.am
parent522ca8179ad2b2b935993f08c9382cd5ad1d8b2f (diff)
Fix 'distcheck' to use host xkb files but install to build dir
'make distcheck' needs to read xkb files and write out compiled versions as a part of the 'make check' phase. This patch passes suitable options to the configure stage of the distcheck process to read xkb files from the system location and write them to the distcheck _inst directory. Signed-off-by: Keith Packard <keithp@keithp.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index cb98d2c31..a5e07307c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -51,6 +51,11 @@ endif
EXTRA_DIST = xorg-server.pc.in xorg-server.m4 ChangeLog autogen.sh
+DISTCHECK_CONFIGURE_FLAGS=\
+ --with-xkb-path=$(XKB_BASE_DIRECTORY) \
+ --with-xkb-bin-directory=$(XKB_BIN_DIRECTORY) \
+ --with-xkb-output='$${datadir}/X11/xkb/compiled'
+
DISTCLEANFILES = doltcompile doltlibtool
MAINTAINERCLEANFILES=ChangeLog