summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJonathan Gray <jsg@jsg.id.au>2013-06-19 11:30:24 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2013-06-19 11:30:24 +0100
commit6132400365f8f467d838ed26002e74412e1c7298 (patch)
treeb207b8728eb4e4722e26592bef0241940f00a8f7 /configure.ac
parentf567f19b37d00131cda749e31c6d2dc8b52a1d62 (diff)
configure: test for librt (clock_gettime)
clock_gettime() is in libc not librt on OpenBSD so check to see if linking librt is required. Signed-off-by: Jonathan Gray <jsg@jsg.id.au>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3f6f9bda..26688a3f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -374,6 +374,10 @@ PKG_CHECK_MODULES(DRI, [xf86driproto], , DRI=no)
PKG_CHECK_MODULES(DRI2, [dri2proto >= 2.6],, DRI2=no)
PKG_CHECK_MODULES(PCIACCESS, [pciaccess >= 0.10])
+LIBS=""
+AC_SEARCH_LIBS(clock_gettime, rt, [CLOCK_GETTIME_LIBS=$LIBS])
+AC_SUBST(CLOCK_GETTIME_LIBS)
+
sdkdir=`$PKG_CONFIG --variable=sdkdir xorg-server`
if test "x$enable_dri" != "xno"; then