summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChad Versace <chad.versace@intel.com>2011-02-23 20:01:02 -0800
committerChad Versace <chad.versace@intel.com>2011-02-25 10:54:38 -0800
commit486a811dbbc50a177d2a5d00b9fed3323eaadcce (patch)
tree1f45d61f0e102aeb550efdf9f25d61fd105f1099 /CMakeLists.txt
parent2875e8ad3ef5f0e78af974e1c461717c84937dc6 (diff)
cmake: Move output paths from piglit_SOURCE_DIR to piglit_BINARY_DIR
This fixes out-of-source builds, and does not harm in-source builds. Signed-off-by: Chad Versace <chad.versace@intel.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 82b31c38..8a5ef9bd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -23,8 +23,8 @@ FIND_LIBRARY(OPENGL_egl_LIBRARY
)
find_library(OPENGL_gles2_LIBRARY NAMES GLESv2)
-set(EXECUTABLE_OUTPUT_PATH ${piglit_SOURCE_DIR}/bin)
-set(LIBRARY_OUTPUT_PATH ${piglit_SOURCE_DIR}/bin)
+set(EXECUTABLE_OUTPUT_PATH ${piglit_BINARY_DIR}/bin)
+set(LIBRARY_OUTPUT_PATH ${piglit_BINARY_DIR}/lib)
add_subdirectory (tests)