summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGerd Hoffmann <kraxel@redhat.com>2010-07-08 11:40:55 +0200
committerAlon Levy <alevy@redhat.com>2010-12-08 17:14:23 +0200
commit3f2997411ec57b4d31e99d4b333d7919741d8968 (patch)
tree51fcb9d41bb6c621f4cb30e00b386591727ae587 /configure.ac
parent1bb1bcb9a0e369b9663951d9ec944f31984ffdf7 (diff)
mingw32 build: disable -fvisibility test for unsupported mingw32 target
Signed-off-by: Gerd Hoffmann <kraxel@redhat.com> v2: only disable for os_win32 (Hans)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5b20e5b..72b377a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -435,7 +435,7 @@ error Need GCC 4.0 for visibility
int main () { return 0; }
], have_gcc4=yes)
-if test "x$have_gcc4" = "xyes"; then
+if test "x$have_gcc4" = "xyes" -a ! "$os_win32" = "yes" ; then
VISIBILITY_HIDDEN_CFLAGS="-fvisibility=hidden"
fi
AC_MSG_RESULT($have_gcc4)