summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2010-01-29 16:33:18 +0100
committerAlexander Larsson <alexl@redhat.com>2010-02-04 16:47:27 +0100
commit193c54c0da71a5feb8fccfefb4de07526ef191c6 (patch)
tree687a9bde59d8c69d30a3eb484a557fe3fe2db720 /configure.ac
parente625b1a1fb672dcb827cd97592f745d9db653c29 (diff)
Add autoconf and pkg-config setup
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..90cb583
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,19 @@
+AC_PREREQ([2.57])
+
+m4_define([SPICE_MAJOR], 0)
+m4_define([SPICE_MINOR], 5)
+m4_define([SPICE_MICRO], 1)
+
+AC_INIT(spice-protocol, [SPICE_MAJOR.SPICE_MINOR.SPICE_MICRO], [], spice-protocol)
+
+AC_CONFIG_MACRO_DIR([m4])
+AM_CONFIG_HEADER([config.h])
+
+AM_INIT_AUTOMAKE([dist-bzip2])
+AM_MAINTAINER_MODE
+
+AC_OUTPUT([
+Makefile
+spice-protocol.pc
+spice/Makefile
+])