summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVarad Gautam <varad.gautam@collabora.com>2016-11-17 17:25:59 +0530
committerDaniel Stone <daniels@collabora.com>2017-06-12 10:37:38 +0100
commitf9dec67990a54afe14d4d2db694bf696ae418bcd (patch)
treed79df373974a228266db9e910a08bfe7b906e4b1 /configure.ac
parentc32e05bbf3bdef6007156146a8dab01770674e38 (diff)
clients/simple-dmabuf-intel: rename to simple-dmabuf-drm
this will allow adding other drm backends later. Signed-off-by: Varad Gautam <varad.gautam@collabora.com> Reviewed-by: Daniel Stone <daniels@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 11 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index c4f5f212..bb337533 100644
--- a/configure.ac
+++ b/configure.ac
@@ -380,19 +380,19 @@ if test x$enable_simple_egl_clients = xyes; then
[egl glesv2 wayland-client wayland-egl wayland-cursor])
fi
-AC_ARG_ENABLE(simple-dmabuf-intel-client,
- AS_HELP_STRING([--disable-simple-dmabuf-intel-client],
- [do not build the simple dmabuf intel client]),,
- enable_simple_dmabuf_intel_client="auto")
-if ! test "x$enable_simple_dmabuf_intel_client" = "xno"; then
- PKG_CHECK_MODULES(SIMPLE_DMABUF_INTEL_CLIENT, [wayland-client libdrm libdrm_intel],
- have_simple_dmabuf_intel_client=yes, have_simple_dmabuf_intel_client=no)
- if test "x$have_simple_dmabuf_intel_client" = "xno" -a "x$enable_simple_dmabuf_intel_client" = "xyes"; then
- AC_MSG_ERROR([Intel dmabuf client explicitly enabled, but libdrm_intel couldn't be found])
+AC_ARG_ENABLE(simple-dmabuf-drm-client,
+ AS_HELP_STRING([--disable-simple-dmabuf-drm-client],
+ [do not build the simple dmabuf drm client]),,
+ enable_simple_dmabuf_drm_client="auto")
+if ! test "x$enable_simple_dmabuf_drm_client" = "xno"; then
+ PKG_CHECK_MODULES(SIMPLE_DMABUF_DRM_CLIENT, [wayland-client libdrm libdrm_intel],
+ have_simple_dmabuf_drm_client=yes, have_simple_dmabuf_drm_client=no)
+ if test "x$have_simple_dmabuf_drm_client" = "xno" -a "x$enable_simple_dmabuf_drm_client" = "xyes"; then
+ AC_MSG_ERROR([DRM dmabuf client explicitly enabled, but libdrm_intel couldn't be found])
fi
- enable_simple_dmabuf_intel_client="$have_simple_dmabuf_intel_client"
+ enable_simple_dmabuf_drm_client="$have_simple_dmabuf_drm_client"
fi
-AM_CONDITIONAL(BUILD_SIMPLE_DMABUF_INTEL_CLIENT, test "x$enable_simple_dmabuf_intel_client" = "xyes")
+AM_CONDITIONAL(BUILD_SIMPLE_DMABUF_DRM_CLIENT, test "x$enable_simple_dmabuf_drm_client" = "xyes")
AC_ARG_ENABLE(simple-dmabuf-v4l-client,
AS_HELP_STRING([--disable-simple-dmabuf-v4l-client],