summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDerek Foreman <derekf@osg.samsung.com>2015-06-17 15:13:48 -0500
committerPekka Paalanen <pekka.paalanen@collabora.co.uk>2015-06-18 14:05:24 +0300
commite06f88cf91384099a45ca5e194bbb12d499b1ff9 (patch)
treeb8a827a1499a3bafeddd1e70f2950a0b3ad38584 /Makefile.am
parent1faeb7ff4894be9649d042103178ce22693cd6d1 (diff)
build: Move AM_CFLAGS and AM_CPPFLAGS to the top of Makefile.am
AM_CFLAGS and AM_CPPFLAGS aren't positional, so putting them at a random place in Makefile.am can be misleading. Signed-off-by: Derek Foreman <derekf@osg.samsung.com> Reviewed-by: Peter Hutterer <peter.hutterer@who-t.net> Reviewed-by: Pekka Paalanen <pekka.paalanen@collabora.co.uk>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 0ea300a..96ad0be 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,6 +4,13 @@ endif
ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
+AM_CPPFLAGS = \
+ -I$(top_builddir)/src \
+ -I$(top_srcdir)/src \
+ -I$(top_builddir)/protocol
+
+AM_CFLAGS = $(GCC_CFLAGS) $(FFI_CFLAGS)
+
aclocaldir = $(datadir)/aclocal
dist_aclocal_DATA = wayland-scanner.m4
@@ -214,12 +221,5 @@ fixed_benchmark_LDADD = libtest-runner.la
os_wrappers_test_SOURCES = tests/os-wrappers-test.c
os_wrappers_test_LDADD = libtest-runner.la
-AM_CPPFLAGS = \
- -I$(top_builddir)/src \
- -I$(top_srcdir)/src \
- -I$(top_builddir)/protocol
-
-AM_CFLAGS = $(GCC_CFLAGS) $(FFI_CFLAGS)
-
exec_fd_leak_checker_SOURCES = tests/exec-fd-leak-checker.c
exec_fd_leak_checker_LDADD = libtest-runner.la