summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSungjae Park <nicesj@nicesj.com>2016-08-09 12:46:51 +0200
committerPekka Paalanen <pekka.paalanen@collabora.co.uk>2016-08-11 14:35:28 +0300
commitbe48da6a42b399252959ef782132fdfdf62c6905 (patch)
tree7c02f2c789371458658a57a9cfb0ade699d9b583 /Makefile.am
parent5636cb2f056d813b464c451754908e17de838e3a (diff)
server: add listener API for new clients
Using display object, Emit a signal if a new client is created. In the server-side, we can get the destroy event of a client, But there is no way to get the created event of it. Of course, we can get the client object from the global registry binding callbacks. But it can be called several times with same client object. And even if A client creates display object, (so there is a connection), The server could not know that. There could be more use-cases not only for this. Giulio: a test is added for the new functionality Signed-off-by: Sung-jae Park <nicesj@nicesj.com> Signed-off-by: Giulio Camuffo <giulio.camuffo@kdab.com> Reviewed-by: Jonas Ã…dahl <jadahl@gmail.com> Reviewed-by: Pekka Paalanen <pekka.paalanen@collabora.co.uk>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 49e25a6..e684a87 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -160,7 +160,8 @@ TESTS = \
signal-test \
resources-test \
message-test \
- headers-test
+ headers-test \
+ compositor-introspection-test
if ENABLE_CPP_TEST
TESTS += cpp-compile-test
@@ -217,6 +218,8 @@ resources_test_SOURCES = tests/resources-test.c
resources_test_LDADD = libtest-runner.la
message_test_SOURCES = tests/message-test.c
message_test_LDADD = libtest-runner.la
+compositor_introspection_test_SOURCES = tests/compositor-introspection-test.c
+compositor_introspection_test_LDADD = libtest-runner.la
headers_test_SOURCES = tests/headers-test.c \
tests/headers-protocol-test.c \
tests/headers-protocol-core-test.c